Inkscape基本操作

维基教科书,自由的教学读本
跳转至: 导航搜索

英文原文 可以參考: http://www.inkscape.org/doc/basic/tutorial-basic.html

基本說明[编辑]

本文將為您介紹基本的 inkscape 操作,您可以很輕鬆的編輯修改本文,當然也可以儲存它。 這一份基本文件包含有 inkscape 的基本操作如: 畫布、元件的移動和放在縮小, 文件管理,繪製圖形工具,物件轉換工具,選擇工具的使用技巧,群組化物件, 填充和線條工具,對齊工具,還有圖層的操作也將在本文裡頭加以說明。

前言[编辑]

本文撰寫乃是根據: inkscape 套件 0.41-4.99.sarge0 版中的說明文件

另有部份說明係根據 http://www.inkscape.org 官方網站的英文版說明文件。

如您還需要更進階的說明,請從 HELP 選單中取出其它的說明文件。

如果您需要 inkscape 的程式下載,請訪問 http://www.inkscape.org

畫布的操作[编辑]

有許多方法可以捲動畫布,您可以試著用 CTRL + 方向鍵來垂直捲動畫布, 當然,如果您不想看到捲動軸,也可以使用 CTRL + B 來隱藏捲動條。 使用 CTRL + SHIFT + 方向鍵 則可以水平捲動畫布。

註:如果你有一隻三鍵滑鼠,您也可以使用中鍵的滾輪加上 CTRL 來做放大、縮小的動作。 SHIFT + 滾輪則是水平方向的畫布移動。

inkscape 工具[编辑]

在左邊垂直的工具列上有 inkscape 的繪圖和編修的工具。 在這個選單底下有命令列和一般的命令按鈕,還有針對每個工具的控制選項。在你開始工作的時候,視窗最底下的訊息列將會告訴您一些操作上的提示和訊息。

如果您還需要更多的快速鍵或操作上的指示,您可以在 inkscape 的工具列上的 HELP> Keys and mouse 裡頭參考相關的指示。

視野的放大與縮小[编辑]

視野的放大縮小最簡單的方法就是按下 "+" 和 "-" 。 您也可以使用 CTRL 加上 右鍵(中鍵)來做視野放大,用 SHIFT 加上 右鍵(中鍵)來做視野的縮小。

創建和管理的工具[编辑]

要開啟一個新的文件,您可以在功能表單上的 File > New 或者是使用快速鍵 CTRL 加上 N 來創建一份新文件。 需要開啟現有文件的話,可以點選 File > Open 或是使用快速鍵 CTRL 加上 O 來開啟這份文件。 儲存文件則是使用 CTRL 加上 S 來保存。 提醒您: inkscape 還沒穩定的釋出版,時常存檔有益健康。

inkscape 將每一個開啟的文件檔視為獨立的文件,所以您可以使用視窗管理程式的 ALT 加上 TAB 作文件間的切換,或使用 inkscape 提供的 CTRL 加上 TAB 快速鍵來切換 inkscape 的文件視窗。

繪製圖形工具[编辑]

是時候讓我們來畫些圖出來了!點擊一下工具列上的繪圖工具(或者按下 F4)然後拖拉一下就可以,當然,您可以在一個空白的文件底下做圖,然後就可以得到如下的圖形:

Inkscape basic-f01.png

如你所見,預設的圖形方塊出來是藍底黑線,還有部份透明的效果。我們接下來會說明如何更改。利用別的工具,可以也可以創建一些圖形像是圓形,星形,還有螺旋圖之類,如下:

Inkscape basic-f02.png

這些工具大部分都是繪製多邊形的工具。你可以使用這些工具控制裡面長得像鑽石形狀的控制點,試著拖拉這些控制點來改變多邊形的外觀。

控制面版是調整圖形的另外一個方式,這些選項可以影響目前選擇的圖形(像是上面提到的控制點)還可以調整預設值,下次再創建一個新圖形時就會以這些預設值來創建元件。

您可以使用 CTRL 加 Z 來回復上一步的動作,或著如果你反悔了,你還是可以用 CTRL 加上 SHIFT 加上 Z 來重做你上一個動作。

移動、放大、旋轉工具[编辑]

在 inkscape 裡面最常用到的工具是「箭頭選擇器」,您可以點選工具列最上面的箭頭來開始使用這個功能,也可以按下 F1 或 SPACE 鍵來使用這個功能。當你啟用了這個功能,就可以在畫布上面選擇物件。 現在你可以點選像下面的這個物件,來開始操作:

Inkscape-basic-f03.png

點下去之後,你就會在這個物件上面看到四周秀出來了八個箭頭指標:

Inkscape-basic-8angle.png

這時你可以對它做:

  • 移動與拖拉(你可以再按下 CTRL 鈕來限制這個物件只能做水平或垂直的移動)
  • 變形與放大縮小(你可以先點一下箭頭就可以開始做變形與放大的操作,如果你一直按著 CTRL 鈕,還可以限制它只能做水平或垂直的變形或放大縮小。)

用快速鍵來修改圖形[编辑]

Inkscape 好用的地方其中有一項跟其它的向量圖形編輯器不一樣的,就是它在鍵盤使用上的便利。 這些我們平常在 Inkscape 做的動作,幾乎沒有不能在鍵盤上面操作的,就連改圖也不例外。

你可以使用鍵盤來移動游標(方向鍵),物件比例放大(括號"<"和">"),物件的旋轉(中括號"["和"]")。預設游標的每次移動和等比例縮放是 2 個像素,你可以使用 SHIFT 鍵來加快它 10 倍的速度。 CTRL 加 ">" 和 CTRL 加 "<" 可以一次對原物件放大 200% 或縮小 50% 。預設每次的旋轉是 15 度,加上 CTRL 鍵,你可以一次旋轉 90 度。

不過,在這些操作裡頭,最有用的還是要算是利用 ALT 加上轉換功能鍵做 pixel-size 的轉換。例如,我們可以用 ALT 加上方向鍵可以在物件所處的空間裡頭移動所選物件一個像素。(也就是一個營幕上的像素,不要跟 SVG 裡面的 px 長度單位搞混了...)。這代表如果你 zoom in ,一個 ALT 加上方向鍵的操作可以在你的營幕上面看到是一個像素的移動...)這樣,你就可以隨意 zoom in/out 還可以精準的移動你想移動的物件

同樣的, ALT 加上 ">" 和 ALT 加上 "<" 可以放大縮小你所選擇的物件,你也可以在 ALT 加上 "[" 和 ALT 加上 "]" 的旋轉操作時,用這個方法來調整營幕上所看到的像素移動。

多重選擇物件的方法[编辑]

你可以 Shift + 滑鼠點擊的方式,一次同時選擇好幾個物件。 或著你也可以用拖拉一個範圍的方式來選擇你想選擇的物件。這種方式被稱作「橡皮筋式的選擇方式」。(你可以像拉橡皮筋一樣的從一個空白的地方開始拖拉, inkscape 就會自動做一個橡皮筋出來把你想選的地方統統圈選起來。)

你可以在下面的物件旁邊練習一下:

Inkscape-basic-f04 path1290.png

現在試試看橡皮筋式的圈選方式:(用拖拉或 shift + 拖拉)的方式選擇兩個圓形物件,不是長方形的物件:

File:Inkscape-basic-rubber-band.png

每個不同的物件被選起來的時候都會秀出來一個 selection cue.預設是一個虛線的方方形框架。這些 cues 會讓你在使用的時候很清楚的看到你所選擇的物件。例如說,如果你同時選了兩個圓形物件跟長方形, 如果不這樣,你會很難猜得出來你到底選了圓形物件了沒。

Shift + 滑鼠點擊的方式也可以將所選擇的物件排除。我們可以先像上面那樣選了三個物件,接著使用 Shift + 滑鼠點擊的方式來練習看看可不可以把圓形物件從選擇物件裡排除,只留下一個長方形物件。

當你按下 ESC 的按鈕時,會把所有你所選擇的物件全部取消掉。 Ctrl + A 可以選擇所有在這個圖層的物件。如果你沒有建立圖層的話,這個物件就只有一個圖層,所有的物件就都放在上面。

群組化物件[编辑]

群組化物件就是把好幾個物件綁到一起,形成一個群組。一個群組的物件拖拉縮放起來,行為會像是一個單一的物件一樣。下面的範例裡,左邊的那三個物件是各自獨立的;在右邊的三個同樣的物件是先群組化過了的。請試著拖拉並將它們群組化在一起。

範例圖片

建立群組最快的方式,你可以先把物件選起來,再按下 CTRL + G 。如果想拆開群組,也可以使用 CTRL + U 來做這個動作。(編按: 因為好記的關係,小編習慣用 CTRL + SHIFT + G 來做這件事情。)群組化的物件動作起來就跟其它的物件是一樣的,你可以再在已經群組化過的物件上面再跟別的物件作群組,當然,你也可以在一個群組化過的物件上面做拆分群組,它自已會按照之前組合的順序加以拆分。

如果想要編輯群組裡面的物件,你大可不必那麼累的還去拆分這個物件,再下去進行編輯動作。直接用 CTRL + 滑鼠點擊的方式下去選擇物件,就可以開始編輯。也可以使用 SHIFT + CTRL + 滑鼠點擊的方式下去一次編輯多個物件(不管在群組物件裡面或外面都可以一起修改)。試試看移動或放大縮小這些群組裡的物件,不要拆開原本的群組設定。

圖形內容填色與線條[编辑]

有很多 Inkscape 的功能得要透過對話方塊才能使用。要用某種顏色畫個物件的方式該是直接打開 Swatches 的對話框就挑顏色給這個物件使用。(當然,你之後也可以用同樣的方式來修改物件的填充顏色)

更快的方式當然還是直接使用 SHIFT + CTRL + F(Fill and Stroke 的對話框),你可以用這個來選擇形狀跟填充、線條顏色等選項。

範例圖片

你可以在對話框上面找到這三個標籤: 填充、線條、及其樣式。 填充的部份可以讓你修改填充(物件內部)的顏色或樣式等等。接著你也可以選擇要不要填充內部,就是只有框架的外觀、或單純的填色、線性漸層、或放射性的漸層等等。只要選了上面的選項,物件內部就會變換做那個樣式。

接著下來,你可以看到一些色盤,像是 RGB, CMYK, HSL 還有輪狀的色盤。這裡面大概算輪狀的色盤是最方便的了。因為你可以自由選擇輪狀色盤裡的 hue 值,也可以直接點擊外面的方塊引導你調色到接近的值。所有的色盤都可以讓你自由調整 alpha 值,選擇物件的透明度。

不論你選了那個物件,色盤都會自動更新上面的指標到你現在所選擇的物件的填色和線條的顏色內容。(如果你一次選了好幾個物件,那麼色盤上面的指標會是它們的"顏色平均值"。)下面的範例你可以先玩玩看~ 範例圖片

用 Stroke paint 標籤裡的工具,你可以很方便的移除物件的外框或框線,當然你也可以指定顏色或透明度給它。 範例圖片

最後一個標籤工具是 "線條樣式" ,這可以讓你調整線條的寬度還有像是線條的外觀要虛線還是實線、箭頭的樣式等等。 範例圖片

最後,除了單一顏色,你也可以指定漸層顏色給物件的內容填色或它的框線。 範例圖片

不管你選了單一的顏色或漸層,新建立的漸層顏色會使用之前的顏色做為初始值。你可以使用漸層工具(可以使用 CTRL+F1 來呼叫)直接拖拉這個漸層的顏色來修改。控制器上用線條的長度還有方向來決定漸層的變化。在控制器上選了一個漸層的顏色時(它會用藍色來特別標註),線條與填色的對話框就會自動將這個顏色設定下去,而不會再理會先前設定的顏色。

還有一個方便的工具可以改變物件的顏色的,就是使用 Dropper tool(你可以用 F7來呼叫),點擊哪裡,就會自動設定這個物件的內容填色為你所點擊的顏色。(如果你用 SHIFT + 滑鼠點擊就是改變它的線條顏色。)

複製、對齊、和物件放置[编辑]

最常見的操作是用 Ctrl + D 來複製一個物件。複製出來的物件會剛剛好就在原來你選擇的那個物件上方。 所以你可以用滑鼠或方向鍵來移動一下你剛剛複製的物件。現在我們可以來練習一下,用黑色的正方形複製到那條線裡面。

範例圖示:

另外,你的正方形複本都是亂數擺放的。這時「對齊」對話框就非常有用了。你可以使用 Ctrl + Shift + A 來呼叫這個對話框。 用 Shift + Click 或拖拉的方式來選擇這些正方形,接著打開對話框,按下 "水平置中" 的選項,然後 "Make horizontal gaps between objects equal" 物件間的水平間距都要相等,的按鈕也選起來。(你可以參閱一下按鈕的工具提示),接著你就會看到物件都放置得剛剛好對齊,水平間隔也都會剛好相同。下面是一些對齊和均放的例子:

範例圖示:

Z-order 圖層順序[编辑]

Z-order 這個字是指物件在圖畫裡的堆放順序;好比是我們有時畫了幾個圖層,有的東西要畫在某些東西上面,Z-order 的值愈高,擺放在圖層裡的位置就愈高,愈容易讓人看見。在 Object 選單裡面有兩個很重要的命令跟它有關: Raise to Top(提昇到最頂端)、還有 Lower to Bottom(調降到最底層),當然,你也可以使用 HOME 跟 END 來做提昇和調降的動作。另外兩個命令是: PAGE-UP 和 PAGE-DOWN 的按鈕,你也可以使用這兩個按鈕來 "逐漸" 提昇/調降物件的 Z-order 。除此之外,在 Paste 一個物件的時候, Z-order 會調高讓這個物件貼在原本的圖層上面,這樣才方便你做提昇調降的動作。

下面最左邊的圓形是在圖層的最上面,最右邊的那個則是在最底下,你可以試著練習運用剛剛我們提到的指令來調整物件的 Z-order,。 範例圖片

在選擇圖層上面有一個很有用的快速鍵是 TAB 鍵。如果沒選擇任何一個東西的時候按下去,它就會自動選擇最底層圖的物件。有選的時候,它就會選擇在這個物件上面的一個物件。 SHIFT + TAB 就會作相反的事情,去選擇在這個物件以下的一個物件,或是最頂層的一個物件。不過我們創建一個新物件或貼上物件都是自動貼到圖層的最上面,所以這個指令 SHIFT + TAB 就沒那麼重要了。下面有幾個疊在一起的圓形,你可以試著看看我們剛剛教的 TAB 和 SHIFT + TAB 指令。

藏在底下也照拖、照改不誤[编辑]

如果你需要的物件是藏在別的物件底下,你該怎麼做?如果上面的物件是(半)透明的就還看得到你想選的物件,不過當你點擊滑鼠下去的時候,你還是只選到它上面的物件,而不是你想選的那一個。

這就是我們設計 ALT + 滑鼠點擊的用途。第一次 ALT + 滑鼠點擊上物件上面的時候,就跟平常的點擊沒什麼兩樣。但是接下來的每一次 ALT + 滑鼠點擊都會選到在這個物件底下一層的物件。如果你想選的東西還在它下面,請多點兩下。它的排列順序是按照圖層裡的 Z-order 來做排列的,所以當你點到最底下的物件的時候,再點一次,它就又會自動跑回第一層的物件。

這個功能不錯吧?應該有人會問說:我選這種被蓋在下面的物件有什麼用?嘿嘿,你還是可以使用快速鍵來修改它的形狀大小等等,加料處理。不過這邊要註記一下,當你使用拖拉的方式下去修改的時候,物件就會自動提升到上面的圖層。如果你想直接拖拉修改,你也可以試試看 ALT + 滑鼠拖拉的方式來修改。它會移動你選擇的物件到不管你拖到那裡。

試試看用 ALT + 滑鼠點擊,還有 ALT + 滑鼠拖拉的方式來改變底下的棕色還有綠色半透明的方塊。 範例圖片

總結[编辑]

這篇文章只有基本的說明而已,在 inkscape 裡面還有很多功能這裡都沒有提到。不過靠這篇文章,你應該已經可以做出些有用的圖片應用了。如果還想要更進一步的說明,你可以在「the Advanced and other tutorials in Help > Tutorials 」選單裡面找到。