Blender 3D︰從入門到精通/3D视图窗口

维基教科书,自由的教学读本
跳到导航 跳到搜索

3D 视图 Blender2693DViewIcon.png 窗口在Blender中用于显示3D场景. 你将会有很多工作在这些窗口中, 因此你需要学习(so you will need to learn your way around).

3D视图显示的内容仅仅是和最终场景近似approximation. 整体上几何体都是正确的, 但材质(materials),纹理(Textures),灯光(lighting)等没有精确显示, 因为那样需要消耗很多时间, 而且3D视图窗口设计用于快速响应你的交互操作。另外,还有其他视图选项(如wireframe、隐藏等),这样可以更容易地查看正在处理的模型的哪些部分,这对最终的渲染没有影响。你也可以随时改变你的视点(这在你的模型/场景中是很重要的),而渲染的视点是由摄像机的位置控制的( Plus there are additional view options (like wireframe, hiding etc) that make it easier to see what parts of the model you’re working on, that have no effect on the final render. Also you can change your viewpoint at any time (which will be essential while working on your model/scene), while the viewpoint of the render is controlled by the camera position.)

在这个模块你将学习:

  • 识别10个在视窗(viewports)中常见的东西
  • 能够说出Blender在哪一个模式(to tell which mode Blender is in)
  • 如何更改视窗设置和视角( viewport options and viewpoints)
  • 如何定位3D光标( 3D cursor)

你也会学到以下的基本知识:

  • 能见度层( visibility layers)

视窗及其内容(The Viewport and its Content)[编辑]

除了顶栏(header),3D视图窗口的其余部分是它的视窗。在Blender中,每当你需要正在处理的场景的最新视图时,就可以使用视窗(viewports)。

视窗是忙碌的地方。进行一次寻宝游戏,看看你能在一个简单的视窗(viewports)上找到什么。

  1. 启动Blender。
  2. 于是这样我们都在看同样的场景(就是面前启动的Blender),(下面说的是怎样使界面回到出厂设置) 加载 出厂设置,点击 File → Load Factory Settings
  1. 确认 清除所有(Erase All) 通过鼠标左键  LMB  (or  Enter ).
  2. 如果键盘上的NumLock指示灯没有亮,按下 NumLock  这样,小键盘就能正常工作了。
  • 在 Blender 2.67a 中, 恢复出厂设置 目录是 "加载默认文件和用户首选项。" 所以它不显示 清除所有(Erase All) 的信息。

(如果你不确定  LMB  是什么意思, 请复习 the Keystroke, Button, and Menu Notation module.)章节的内容(尽管我已经标了出来)。

你应该看到这样的东西:

Blender-2.57 viewport outline.png
在这里,视窗viewport就是被 红色 圈起来的地方,把注意力集中在它上面。

一个虚拟的寻宝游戏[编辑]

查看Blender创建者提供的默认场景中的视窗viewport,找到以下8项:

在中心

1. Blender-2.5 cube object mode.PNG 一个有橙色边缘的灰色立方体。

  • 这就是

默认的多维数据库 default cube , 你的第一个Blender 对象!

2. Blender 3D Manipulator screenshot.png 三个大箭头,一个红的,一个绿的,一个蓝的,它们的尾巴组成了一个白色的圆圈

  • 这不是对象(您的模型/场景的一部分),而是处理对象的Blender用户界面的一部分。这是操纵器manipulator, 也被称为3D变换组件 3D transform widget.
  • 箭头表示正确选择的 X, YZ 轴的方向, 这是一个变向transform orientation 坐标系。它默认为全局坐标系 global coordinate system.
  • 圆圈表示所选对象(即立方体)的中心。
  • 如果你不知道什么是“全局坐标系”,请复习 the module on Coordinate Spaces in Blender.

3. Blender 2.49b cursor.png A red-and-white striped circle with black cross-hairs

  • This is not an object. It is the 3D Cursor, which indicates where newly-created objects will appear in the scene.
  • The cursor is similar to the insertion point in a text editor, which indicates where newly-typed text will appear in a document.
In the Lower Left Corner

4. Blender 3D mini axis screenshot.png

  • This is not an object. It is the mini axis, and its orientation matches that of the global coordinate system, with the usual conventions: red for X, green for Y and blue for Z. Think of it as a little compass, reminding you which way is left/right, front/back and up/down.

5. The notation "(1) Cube"

This is not an object. It is object info, indicating that:
  • You're viewing the first frame of an animation.
and
  • The current or most recently selected object is named "Cube".
In the Upper Left Corner

6. The notation “User Persp”

This is not an object. This is telling you something about the view being displayed by the viewport. The first word will change if you select one of the perfect views or the camera view (see below), otherwise it just says “User”, and the second word is “Persp” or “Ortho” to indicate whether this is a perspective or orthographic view.
To the Right of Center

7. Blender 2.49b lamp icon.png A black round thing that resembles a sun-symbol

This represents a lamp, a light source for the scene. (It is an object.)

8. Blender 2.49b camera icon.png A pyramidal wireframe thing

This represents a camera, a viewpoint that can be used for rendering. (It, too, is an object.) The direction it is looking is out the base of the pyramid. The solid triangle attached to one side of the base is to remind you which way is up in the image that the camera takes.
On a small display, the camera might initially lie outside of the viewport and thus be invisible. In that case, zoom out by scrolling with  MMB  until it becomes visible.
Throughout

9. A dark gray background, divided into squares by lighter lines. This is the grid floor, which you can (but don’t have to) use as a ground plane for positioning your models.

Each grid square is one blender unit (or BU) on a side. A BU can be whatever you wish: an inch, a centimetre, a mile, or a cubit. Blender lets you decide what the scale should be for your scene in the Scene tab of the Properties Panel.

10. Three mutually-perpendicular coloured lines associated with the grid floor: the red and green ones lying horizontally in the floor and the blue one running vertically. These are the global coordinate axes for orienting your scene: as usual, red is the X-axis, green the Y-axis, and blue the Z-axis.

  • In Blender 2.67a, you can't see the blue line for Z-axis here because you can see it in Front or Side view.

Modes[编辑]

Blender has lots of modes, that is, settings that affect its behavior, and this is especially true of 3D View windows.

Sometimes it's not obvious what modes are active. This leads to mode errors where Blender will do something you didn't expect because you thought it was in one mode and it was actually in another.

In Blender, the function performed by a hotkey or mouse button can depend on:

  • what mode the user interface is in,
  • whether the keyboard is in NumLock mode,
  • which window is active,
  • the mode the active window is in,
  • which item or items are selected,
  • whether you've initiated a hotkey sequence.

It helps to recognize the common modes and get out of them.

物体模式(Object Mode)和编辑模式(Edit Mode)的对比[编辑]

3D视图窗口一般处在物体模式,这个模式:

    • 鼠标是一个白色箭头(在 MacOS 中是黑色的)。
    •  RMB  被用来选择屏幕上的物体。

如果在镜头中有物体存在,你可以转换到以下五个模式:

  • 编辑模式(Edit Mode):用来编辑物体的形状。
    • 此时鼠标是一个反相显示的小叉叉。
    •  RMB  被用来选择当前物体的顶点、面或边缘。
    • 按下  Tab  进入或离开这个模式。
  • 雕塑模式(Sculpt Mode)
    • 此时鼠标是一个细长橙环。
  • 顶点绘制(Vertex Paint)
    • 这时的鼠标和雕塑模式一样,是一个细长橙环。
  • 质感绘制(Texture Paint)
    • 此时鼠标是一个细长白环。
  • 权重绘制(Weight Paint)
    • 此时鼠标又是一个细长橙环。

这些模式也显示在3D视图顶部的菜单中。

Blender-2.5 mode menu.png

这些模式在不同的3D视图窗口间是联动的。换句话说,如果你在一个窗口改变了模式,任何其他3D视图窗口的模式也随之变化。

Viewport Options[编辑]

Solid vs. Wireframe[编辑]

By default, the 3D View window draws objects using the Solid drawtype, in which surfaces are opaque. To toggle between Solid and Wireframe drawtype (edges only, no faces) for a particular viewport:

  1. Activate the 3D View window.
  2. Press  Z .

Alternatively, you can choose these and other drawtypes from the "Draw type" menu in the 3D View window header.

Orthographic vs. Perspective[编辑]

By default, viewports draw orthographic views. To toggle a viewport between orthographic and perspective views:

  1. Activate the 3D View window.
  2. Press  Num5 .

(If you're unsure what the difference is, please review "Orthographic Views" 一节 and "Perspective Views" 一节.)

Note this perspective versus orthographic setting for the 3D viewport is completely separate from the similar setting in the camera properties; the former takes effect while you’re working on the model, the latter when you render.

So why have this separate setting for the 3D view? It’s because, regardless of what you want for the final render, certain aspects of modelling are easier in one view than another. If the final render will be using perspective, then naturally showing perspective in the 3D view gives you a better idea of how the final render will look. But perspective foreshortening can sometimes make it hard to ensure the model has the proper shape, which is why there is the option to flip to orthographic view if it helps.

Changing Your Viewpoint, Part One[编辑]

Each viewport has a viewpoint, which takes into account:

  • the location of the viewer in the 3D scene (There doesn't need to be an object at that location.)
  • the direction the viewer is looking
  • the magnification (or zoom factor) used

Changing your viewpoint allows you to navigate your way through a 3D scene.

We'll start with three very basic techniques:

  • Zooming
  • Orbiting/View Rotation
  • Perfect Views.

Additional techniques will be covered later in this module.

Zooming[编辑]

Blender offers several ways to zoom in and out:

  • Use  SCROLL 
  • Click and drag vertically with  Ctrl + MMB .
  • Use  Num+  and  NUM−  to zoom in and out in small increments.

Note the following limitations of Blender's zoom feature:

  • If the viewport is in orthographic mode, Blender zooms as if looking through a telescope. You can increase the magnification, but the viewpoint's location doesn't change. For this reason, you cannot zoom into or through objects in orthographic mode.
  • If the viewport is in perspective mode, Blender zooms to a point—namely the center of the viewport. The viewpoint can pass through objects, but it can't pass beyond this point, no matter what you do. Zooming only gets slower and slower and slower. If the center of the viewport is somewhere you don't expect, zooming may appear to be broken.

Orbiting and View Rotation[编辑]

Let's fly around in the default cube, viewing it from different angles. In this way you'll see that it really is a cube, centered on the origin, half above the X-Y plane and half below it.

  1. Activate the 3D View window by placing the mouse pointer inside it.
  2. Now you can:
    • Click and drag with  MMB  to orbit freely around the center of the view.
    • Use  Shift + Alt + SCROLL  to rotate the viewpoint vertically around the center of the view.
    • Use  Num2  and  Num8  to rotate the viewpoint vertically around the center of the view in 15-degree increments.
    • Use  Ctrl + Alt + SCROLL  to rotate the viewpoint around the Z axis.
    • Use  Num4  and  Num6  to rotate the viewpoint around the Z axis in 15-degree increments.

If this is all very confusing for you, don't worry! You'll learn as you get more experience.

When you are finished flying around the cube, you can restore the original view by reloading the factory settings with File → Load Factory Settings.

Perfect Views[编辑]

It's often useful to get a perfect view of a scene—in other words, to view it along one of the main axes, with the other two main axes oriented up-down and left-right.

Perfect View Hotkeys
Hotkey View Axis Pointing Right Axis Pointing Up
 Num7  "top" +X +Y
 Ctrl + Num7  "bottom" +X -Y
 Num1  "front" +X +Z
 Ctrl + Num1  "rear" -X +Z
 Num3  "right side" +Y +Z
 Ctrl + Num3  "left side" -Y +Z

The following screenshot shows all three perfect views plus camera perspective for the Suzanne primitive:

Blender-2.5 perfect view quad.png

In fact, this layout of four viewports showing top, front and right views plus camera view is so commonly used that it has its own menu item (from the “View” menu, select “Toggle Quad View”) and keyboard shortcut ( CTRL + ALT + Q ).

Positioning the 3D Cursor[编辑]

Positioning the 3D cursor is a very basic operation, yet one that many beginners find challenging. It touches on an issue common to all 3D graphics software: "How do you specify points in a 3D scene when we can only see two dimensions at a time?"

Basic Technique[编辑]

  1. Go into either Object Mode or Edit Mode.
  2. Move the mouse pointer to the desired position (in any viewport).
  3. Click  LMB .

Template:Warning

Template:Warning

Two Challenges[编辑]

Challenge #1. Using only tools presented thus far, try positioning the 3D cursor on the virtual camera.

Try it!

When you're done, check your work by orbiting the camera.

Perhaps you thought you were done when you clicked on the camera. But the moment you changed your viewpoint, you probably found that the 3D cursor was actually behind (or in front of) the camera.

Hints:

  • Try positioning the cursor in two different perfect views.
  • Use orthographic views, not perspective ones.

Challenge #2. Using only tools presented thus far, try repositioning the 3D cursor at the origin (that is, at the center of the cube).

As before, check your work by orbiting the cube. Don't spend too much time on this.

More Ways to Position the Cursor[编辑]

Blender-2.5 snap menu.png

Here's an easy way to position the cursor at the center of an object:

  1. Make sure Blender is in Object Mode, with the object selected.
  2. Move the mouse pointer to any 3D View window.
  3. Snap the cursor to the selected object using either:
    •  Shift + S  Cursor to Selected
    or
    • Object → Snap → Cursor to Selected

Here's 2 easy ways to relocate the cursor to the scene's origin (0, 0, 0):

  1. Move the mouse pointer to any 3D View window.
  2. Press  Shift + C  to reset the cursor to the origin.
    • Note that this also changes the view location, meaning that when you zoom in, you won't zoom in to the scene origin.
  3. A better way is to click Object → Snap → Cursor to Center
    • You can also do this by  Shift + S Cursor to Center.

Changing Your Viewpoint, Part Two[编辑]

Now you'll learn some additional techniques for obtaining the view you want:

  • Panning
  • Centering
  • Jumping to the camera's viewpoint
  • Zooming in on a selected area

Panning[编辑]

When you orbited the cube, the viewpoint's position and direction both changed at the same time. You also can shift the viewpoint up-down or left-right without changing its direction. (This is similar to the side-scrolling effect in the classic Mario and Sonic video games.)

This is called panning, and it's an important skill to master. Try it now:

  1. Activate a 3D View window by placing the mouse pointer inside it.
  2. Now you can:
    • Use  Shift + SCROLL  to pan up and down.
    • Use  Ctrl + Num2  and  Ctrl + Num8  to pan up and down in small increments.
    • Use  Ctrl + SCROLL  to pan left and right.
    • Use  Ctrl + Num4  and  Ctrl + Num6  to pan left and right in small increments.
    • Click and drag with  Shift + MMB  or  Shift + Alt + LMB  to pan freely in the viewplane.


You will likely find this to be a distraction in some cases. To move the viewpoint position back to the center, snap the cursor to the center, then click View → Align View → Center View to Cursor. You could also snap the cursor to the center then press  Ctrl + Num. .

Centering[编辑]

When you zoom or rotate the view, you always zoom or rotate around the center of the view.

To center the view on an arbitrary point:

  1. Move the 3D cursor to the point of interest.
  2. Verify the cursor position from a second viewpoint.
  3. Press  Alt + Home  to center the view.

To center the view on an object in the scene:

  1. Make sure Blender is in Object Mode.
  2. Zoom out until the object is in the viewport.
  3. If any objects are selected, use  A  (or Select → Select/Deselect All) to deselect them.
  4. Select the object of interest by clicking  RMB  on it.
  5. Press  Num.  to center the view.

Jumping to the Camera's Viewpoint[编辑]

To see the scene as the virtual camera sees it, press  Num0 . Afterwards, you can rotate, pan, and zoom normally, but the virtual camera will not follow. To go back to your previous view, press  Num0  again. (In the latest versions of Blender, the virtual camera can be made to follow all the changes made in viewpoint while in camera view by checking the option "Lock Camera to View" on the Transform panel. Hit "N" on your keyboard to bring the transform panel. To disable this option you can uncheck that and get back to previous settings.)

Zooming into a Selected Area[编辑]

Suppose you want to get an extreme closeup of a particular area. Because there's no center mark on the viewport, you might have to pan and zoom several times to get the desired view.

The shortcut for zooming to an area is:

  1. Activate a 3D view window that contains the area of interest.
  2. Press  Shift + B . A crosshair appears in the viewport.
  3. Click and drag with  LMB  to draw a rectangle around the area of interest.
  4. When you release  LMB , the viewport will zoom in on the area you selected.

Fly Mode[编辑]

Another way of changing your viewpoint in the 3D view is with “Fly Mode”. To activate this, press  SHIFT + F . Now you can use the mouse wheel to apply forward and backward “thrust”: scroll up to accelerate forwards, scroll down to accelerate backwards, and leave the wheel alone to coast at constant speed. Also move the mouse (without pressing any buttons) to alter your orientation, up, down, left or right (the velocity vector will stay parallel to your forward/backward axis).

When you have reached the position and orientation you want, press  LMB  or  ENTER  to exit Fly Mode and stay there, or  RMB  or  ESC  to exit Fly Mode and be teleported immediately back to your original position and orientation.

Visibility Layers[编辑]

Every object in the scene is assigned to one of 20 visibility layers.

Visibility layers have many uses:

  • You can put scenery, characters, particles, and lamps in different layers, to help organize your scene.
  • By changing which layers are visible, you can simplify your view of the scene and work with only one or two layers at a time.
  • When rendering, only visible layers are included. You can use this to render your scene layer by layer, checking each layer separately.
  • You can configure lamps to illuminate only objects in the same layer.
Left: Viewing layer 1 only.
Right: Viewing all 20 layers.

In Object Mode, you can tell which layers are visible by looking at the twenty small boxes located in the 3D View header between the Transform Orientation menu and the "Lock" button. The top row of boxes represents layers 1 through 10, with 1 being the leftmost and 10 being the rightmost. Similarly, the bottom row of boxes represents layers 11 through 20.

Hotkeys[编辑]

  • To view just one of layers 1 .. 9, press  1KEY  ..  9KEY .
  • To view just layer 10, press  0Key .
  • To view just one of layers 11 .. 19, press  ALT + 1KEY  ..  ALT + 9KEY 
  • To view just layer 20, press  ALT + 0KEY .
  • To toggle the visibility of one of layers 1 .. 9 without affecting the visibility of the other layers, press  SHIFT + 1KEY  ..  SHIFT + 9KEY .
  • To toggle the visibility of layer 10 without affecting the visibility of the other layers, press  SHIFT + 0KEY .
  • To toggle the visibility of one of layers 11 .. 19 without affecting the visibility of the other layers, press  ALT + SHIFT + 1KEY  ..  ALT + SHIFT + 9KEY .
  • To toggle the visibility of layer 20 without affecting the visibility of the other layers, press  ALT + SHIFT + 0KEY .
  • To make all layers visible at once, press  ~ . Press  ~  again to return to your previous layer visibility setting.


Holding down  Shift  while selecting a layer (by keyboard or mouse) will, instead of making only that layer visible, toggle the visibility. In this way, you can select combinations or to hide particular layers.

The key to press to select all layers at once differs by keyboard layout. It is:

  •  ¬'  (the key under Esc) on UK keyboards,
  •  `~  on US ones,
  •  ö  on German, Swedish and Finnish ones,
  •  æ  on Danish ones,
  •  ù  on AZERTY ones,
  •  ø  on Norwegian ones,
  •  Ñ  on Spanish ones,
  •  "  on Brazilian Portuguese ones, and
  •  ò  on Italian ones.

After pressing the aforementioned key, holding down  Shift  while pressing it again will restore the visibility settings you had before you made all layers visible.

When only one layer is selected, new objects are automatically assigned to that layer. When two or more layers are visible, new objects are assigned to the layer that became visible most recently.

Count Your Polys[编辑]

If you want to count the polygons in your scene, this data is available in the Info Header.

Blender-2.5 polycount.png

As you can see in the above image, this scene has 507 vertices and 500 faces (polygons).