LibreOffice 3.4入门/打印,导出和电子邮件

维基教科书,自由的教学读本
跳到导航 跳到搜索

Introduction[编辑]

This chapter provides general information about printing, exporting, and e-mailing documents from LibreOffice.

Quick printing[编辑]

Click the Print File Directly icon [[Image:]] to send the entire document to the default printer defined for your computer.


Note
You can change the action of the Print File Directly icon to send the document to the printer defined for the document instead of the default printer for the computer. Go to Tools > Options > Load/Save > General and select the Load printer settings with the document option.

Controlling printing[编辑]

Note for Mac users
If you prefer to use the standard Mac Print dialogs, deselect the Print dialogs – Use LibreOffice dialogs option in LibreOffice > Preferences > General.

This book uses the LibreOffice Print dialogs in illustrations.

For more control over printing, use the Print dialog (File > Print or Ctrl+P).

[[Image:|thumb|Figure 263. The Print dialog]]

The Print dialog has four tabs, from which you can choose a range of options, as described in the following sections.


Note
The options selected on the Print dialog apply to this printing of this document only.

To specify default printing settings for LibreOffice, go to Tools > Options > LibreOffice – Print and Tools > Options > LibreOffice Writer – Print. See Chapter 2, Setting Up LibreOffice, for more details.

The different components of LibreOffice have different available print settings, as summarized in Table 3.

Table 3: Print options in LibreOffice components


Feature Writer Calc Impress Draw
Select pages/sheets/slides to print Yes Yes Yes Yes
Print multiple pages/sheets/slides on one page Yes Yes Yes Yes
Print a brochure Yes No Yes Yes
Print envelopes Yes No No No
Print labels or business cards Yes No No No
Preview pages/sheets before printing Yes Yes No No

Selecting general printing options[编辑]

On the General tab of the Print dialog, you can choose:

  • The printer (from the printers available)
  • Which pages to print, the number of copies to print, and whether to collate multiple copies (Range and copies section)
  • Whether to print any comments that are in the document, and where to print the comments.

Some selections may not be available all the time. For example, if the document contains no comments, the Print – Comments drop-down list does not work.

[[Image:|thumb|Figure 264: Choosing whether and where to print comments]]

Select the Properties button to display a dialog where you can choose portrait or landscape orientation, which paper tray to use, and the paper size to print on.

On the Options tab of the Print dialog (Figure 265), the last item, Use only paper tray from printer preference, is not available in Calc.

[[Image:|thumb|Figure 265: General print options]]

Printing multiple pages on a single sheet of paper[编辑]

You can print multiple pages of a document on one sheet of paper. To do this:

  1. In the Print dialog, select the Page Layout tab (Figure 266).
[[Image:|thumb|Figure 266: Printing multiple page per sheet of paper]]
  1. In the Layout section, select from the drop-down list the number of pages to print per sheet. The preview panel on the left of the Print dialog shows how the printed document will look.

When printing more than 2 pages per sheet, you can choose the order in which they are printing across and down the paper.

[[Image:]]
  1. In the Page sides section, select whether to print all pages or only some pages. Click the Print button.


Tip
In Writer, to print two pages per sheet in “facing pages” (book layout) style, print from Print Preview instead. See page 270.

Selecting pages/sheets/slides to print[编辑]

In addition to printing a full document, you can choose to print individual pages/sheets/slides, ranges of pages/sheets/slides, or a selection of a document. The details vary slightly in Writer, Calc, Draw and Impress, as described in this section.

Writer[编辑]

Printing an individual page:

  1. Choose File > Print from the menu bar.
  2. On the Print dialog, select the page to print.
    1. In the Ranges and copies section of the General page, select the Pages option.
    2. Enter the sequence number of the page you want to print. This may differ from the page number if you have restarted page numbering within the document. The preview box changes to show the selected page.
  3. Click the Print button.

Printing a range of pages:

  1. Choose File > Print from the menu bar.
  2. On the Print dialog, select the range of pages to print.
    1. In the Ranges and copies section of the General page, select the Pages option.
    2. Enter the sequence numbers of the pages to print (for example, 1–4 or 1,3,7,11).
  3. Click the Print button.

Printing a selection of text:

  1. In the document, select the material (text and graphics) to print.
  2. Choose File > Print from the menu bar.
  3. The Ranges and copies section of the Print dialog now includes a Selection option and the preview box shows the selected material. See Figure 267.
  4. Click the Print button.
[[Image:|thumb|Figure 267: Printing a selection of text]]

Calc[编辑]

You can choose single sheets, multiple sheets, and selections of cells for printing.

[[Image:|thumb|Figure 268: Choosing what to print in Calc]]

Printing an individual sheet:

  1. In the spreadsheet, click on the sheet tab to select the sheet you want to print.
  2. Choose File > Print from the menu bar.
  3. In the Ranges and copies section of the Print dialog, choose the Selected sheets option.
  4. Click the Print button.

Printing a range of sheets:

  1. In the spreadsheet, select the sheets to print.
    1. Select the first sheet.
    2. Hold down the Control key.
    3. Click on the additional sheet tabs.
    4. Release the Control key when all required sheets are selected.
  2. Choose File > Print from the menu bar.
  3. In the Ranges and copies section of the Print dialog, choose the Selected sheets option.
  4. Click the Print button.

Printing a selection of cells:

  1. In the document, select the section of cells to print.
  2. Choose File > Print from the menu.
  3. In the Ranges and copies section of the Print dialog, select the Selected cells option.
  4. Click the Print button.


Caution
[[Image:]]
After printing, be sure to deselect the extra sheets. If you keep them selected, the next time you enter data on one sheet, you enter data on all the selected sheets. This might not be what you want.

Impress and Draw[编辑]

You can choose individual slides, ranges of slides, or selections of slides for printing.

[[Image:]]

Printing an individual slide:

  1. Choose File > Print from the menu bar.
  2. Select the slide to print.
    1. In the Ranges and copies section of the Print dialog, select the Slides option.
    2. Enter the number of the slide to print.
  3. Click the Print button.

Printing a range of pages:

  1. Choose File > Print from the menu bar.
  2. Select the slides to print.
    1. In the Ranges and copies section of the Print dialog, select the Slides option.
    2. Enter the number of the slides to print (for example 1-4 or 1,3,7,11).
  3. Click the Print button.

Printing a selection of a slide, or a selection from multiple slides:

  1. In the document, select the section of the slide to print.
  2. Choose File > Print from the menu bar.
  3. Select the Selection option in the Ranges and copies section of the Print dialog.
  4. Click the Print button.

Printing handouts, notes, or outlines in Impress[编辑]

Handouts prints the slides in reduced size on the page, from one to nine slides per page. The slides can be printed horizontally (landscape orientation) or vertically (portrait orientation) on the page.

Notes prints a single slide per page with any notes entered for that slide in Notes View.

Outline prints the title and headings of each slide in outline format.

To print handouts, notes, or outlines:

  1. Choose File > Print from the menu bar.
  2. In the Print section of the Print dialog, select the required option.
  3. For Handouts, you can then choose how many slides to print per page, and the order in which they are printed.
  4. Click the Print button.
[[Image:]]

Printing a brochure[编辑]

In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of paper, arranged so that when the printed pages are folded in half, the pages are in the correct order to form a booklet or brochure.


Tip
Plan your document so it will look good when printed half size; choose appropriate margins, font sizes, and so on. You may need to experiment.

To print a brochure on a single-sided printer:

  1. Choose File > Print.
  2. In the Print dialog, click Properties.
  3. Check the printer is set to the same orientation (portrait or landscape) as specified in the page setup for your document. Usually the orientation does not matter, but it does for brochures. Click OK to return to the Print dialog.
  4. Select the Page layout tab in the Print dialog.
  5. Select the Brochure option.
  6. In the Page sides section, select Back sides / left pages option from the Include drop-down list.
[[Image:]]
  1. Click the Print button.
  2. Take the printed pages out of the printer, turn the pages over, and put them back into the printer in the correct orientation to print on the blank side. You may need to experiment a bit to find out what the correct arrangement is for your printer.
  3. On the Print dialog, in the Page sides section, select Front sides / right pages option from the Include drop down box.
  4. Click the Print button.


Tip
If your printer can print double-sided automatically, choose All pages.

Printing envelopes, labels, business cards[编辑]

Printing envelopes, labels, or business cards using Writer involves two steps: setup and printing.

For details of how to set these up, see Chapter 11, Using Mail Merge, in the Writer Guide. To print:

  1. Choose File > Print from the menu bar.
  2. On the Print dialog, under Ranges and copies, choose Pages and type 1 in the box. Click the Print button.

Printing in black and white (on a color printer)[编辑]

You may wish to print documents in black and white on a color printer. Several choices are available. Please note that some color printers may print in color regardless of the settings you choose.

Change the printer settings to print in black and white or grayscale:

  1. Choose File > Print to open the Print dialog.
  2. Click Properties to open the Properties dialog for the printer. The available choices vary from one printer to another, but you should find options for the Color settings. See your printer’s help or user manual for more information.
  3. The choices for color might include black and white or grayscale. Choose the required setting.
  4. Click OK to confirm your choice and return to the Print dialog,
  5. Click the Print button to print the document.


Tip
Grayscale is best if you have any graphics in the document.

Change the LibreOffice settings to print all color text and graphics as grayscale:

  1. Choose Tools > Options > LibreOffice > Print.
  2. Select the Convert colors to grayscale option. Click OK to save the change.
  3. Open the Print dialog (File > Print).
  4. Click the Print button to print the document.

Change the LibreOffice Writer (or Calc, Impress, Draw) settings to print all color text as black, and all graphics as grayscale:

  1. Choose Tools > Options > LibreOffice Writer > Print.
  2. Under Contents, select the Print text in black option. Click OK to save the change.
  3. Open the Print dialog (File > Print).
  4. Click the Print button to print the document.

Previewing pages/sheets before printing[编辑]

You can use the previewing options in Writer and Calc to view the document as it will be printed. Different viewing options are available.

Writer[编辑]

The normal page view in Writer shows you what each page will look like when printed and you can edit the pages in that view. If you are designing a document to be printed double-sided, you may want to see what facing pages look like. Writer provides two ways to do this:

  • View Layout (editable view): use the Facing Pages (Book Preview) button on the status bar.
[[Image:]]
  • Page Preview (read-only view).

To use Page Preview:

  1. Choose File > Page Preview (or click the Page Preview button [[Image:]] on the Standard toolbar).

Writer now displays the Page Preview toolbar instead of the Formatting toolbar.

[[Image:|thumb|Figure 269. Page Preview toolbar (Writer)]]
  1. Select the required preview icon: Two Pages ([[Image:]]), Multiple Pages ([[Image:]]) or Book Preview ([[Image:]]).
  2. To print the document from this view, click the Print document icon([[Image:]]) to open the Print dialog. Choose the print options and click the Print button.

Calc[编辑]

To preview the sheets in Calc before printing:

  1. Choose File > Page Preview.

The Calc window now displays the Page Preview toolbar instead of the Formatting toolbar.

[[Image:|thumb|Figure 270. Page Preview toolbar (Calc)]]
  1. To print the document from this view, click the Print document icon [[Image:]] to open the Print dialog.
  2. Choose the print options and click the Print button.

Exporting to PDF[编辑]

LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file format is ideal for sending the file to someone else to view using Adobe Reader or other PDF viewers.

The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few minor differences mentioned in this section.

Quick export to PDF[编辑]

Click the Export Directly as PDF icon [[Image:]] to export the entire document using the PDF settings you most recently selected on the PDF Options dialog. You are asked to enter the file name and location for the PDF file, but you do not get a chance to choose a page range, the image compression, or other options.

Controlling PDF content and quality[编辑]

For more control over the content and quality of the resulting PDF, use File > Export as PDF. The PDF Options dialog opens. This dialog has five pages (General, Initial View, User Interface, Links, and Security). Select the appropriate settings, and then click Export. Then you are asked to enter the location and file name of the PDF to be created, and click Save to export the file.

General page of PDF Options dialog[编辑]

On the General page, you can choose which pages to include in the PDF, the type of compression to use for images (which affects the quality of images in the PDF), and other options.

Range section

  • All: Exports the entire document to PDF.
  • Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single pages, use the format 7;9;11 (pages 7, 9, and 11). You can also export a combination of page ranges and single pages, by using a format like 3-6;8;10;12.
  • Selection: Exports all the selected material.
[[Image:|thumb|Figure 271: General page of PDF Options dialog]]

Images section

  • Lossless compression: Images are stored without any loss of quality. Tends to make large files when used with photographs. Recommended for other kinds of images or graphics.
  • JPEG compression: Allows for varying degrees of quality. A setting of 90% works well with photographs (small file size, little perceptible loss of quality).
  • Reduce image resolution: Lower-DPI (dots per inch) images have lower quality. For viewing on a computer screen generally a resolution of 72dpi (for Windows) or 96dpi (GNU/Linux) is sufficient, while for printing it is generally preferable to use at least 300 or 600 dpi, depending on the capability of the printer. Higher dpi settings greatly increase the size of the exported file.


Note
EPS (Encapsulated PostScript) images with embedded previews are exported only as previews. EPS images without embedded previews are exported as empty placeholders.

General section

  • PDF/A-1a: PDF/A is an ISO standard for long-term preservation of documents, by embedding all the information necessary for faithful reproduction (such as fonts) while forbidding other elements (including forms, security, and encryption). PDF tags are written. If you select PDF/A-1a, the forbidden elements are grayed-out (not available).
  • Tagged PDF: Tagged PDF contains information about the structure of the document’s contents. This can help to display the document on devices with different screens, and when using screen reader software. Some tags that are exported are table of contents, hyperlinks, and controls. This option can increase file sizes significantly.
  • Create PDF form - Submit format: Choose the format of submitting forms from within the PDF file. This setting overrides the control’s URL property that you set in the document. There is only one common setting valid for the whole PDF document: PDF (sends the whole document), FDF (sends the control contents), HTML, and XML. Most often you will choose the PDF format.
  • Export bookmarks: Exports headings in Writer documents, and page or slide names in Impress and Draw documents, as “bookmarks” (a table of contents list displayed by most PDF viewers, including Adobe Reader).
  • Export comments: Exports comments as PDF notes. You may not want this!
  • Export automatically inserted blank pages: If selected, automatically inserted blank pages are exported to the PDF. This is best if you are printing the PDF double-sided. For example, books usually have chapters set to always start on an odd-numbered (right-hand) page. When the previous chapter ends on an odd page, LibreOffice inserts a blank page between the two odd pages. This option controls whether to export that blank page.
  • Embed standard fonts: Normally the 14 standard PostScript fonts are not embedded in a PDF file, because PDF reader software already contains these fonts. However, you can choose to embed these fonts in all PDF documents created by LibreOffice to enhance display accuracy in PDF viewers. Font embedding may also be required by some printers.
  • Create hybrid file: When the PDF Import Extension is installed, this option exports the document as a .PDF file containing two file formats: PDF and ODP. This extension is bundled with most installations of LibreOffice.

Initial View page of PDF Options dialog[编辑]

On the Initial View page (Figure 272), you can choose how the PDF opens by default in a PDF viewer. The selections should be self-explanatory.

If you have Complex Text Layout enabled (in Tools > Options > Language settings > Languages), an additional selection is available under Continuous facing: First page is left (normally, the first page is on the right when using the Continuous facing option).

User Interface page of PDF Options dialog[编辑]

On the User Interface page (Figure 273), you can choose more settings to control how a PDF viewer displays the file. Some of these choices are particularly useful when you are creating a PDF to be used as a presentation or a kiosk-type display.

Window options section

  • Resize window to initial page. Causes the PDF viewer window to resize to fit the first page of the PDF.
  • Center window on screen. Causes the PDF viewer window to be centered on the computer screen.
  • Open in full screen mode. Causes the PDF viewer to open full-screen instead of in a smaller window.
[[Image:|thumb|Figure 272: Initial View page of PDF Options dialog]]
[[Image:|thumb|Figure 273: User Interface page of PDF Options dialog]]
  • Display document title. Causes the PDF viewer to display the document’s title in the title bar.

User interface options section

  • Hide menubar. Causes the PDF viewer to hide the menu bar.
  • Hide toolbar. Causes the PDF viewer to hide the toolbar.
  • Hide window controls. Causes the PDF viewer to hide other window controls.

Transitions

In Impress, displays slide transition effects as their respective PDF effects.

Bookmarks

Select how many heading levels are displayed as bookmarks, if Export bookmarks is selected on the General page.

Links page of PDF Options dialog[编辑]

On the Links page, you can choose how links are exported to PDF.

[[Image:|thumb|Figure 274: Links page of PDF Options dialog]]

Export bookmarks as named destinations

If you have defined Writer bookmarks, Impress or Draw slide names, or Calc sheet names, this option exports them as “named destinations” to which Web pages and PDF documents can link.

Convert document references to PDF targets

If you have defined links to other documents with OpenDocument extensions (such as .ODT, .ODS, and .ODP), this option converts the files names to .PDF in the exported PDF document.

Export URLs relative to file system

If you have defined relative links in a document, this option exports those links to the PDF.

Cross-document links

Defines the behavior of links clicked in PDF files.

Security page of PDF Options dialog[编辑]

PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and apply some digital rights management (DRM) features.

  • With an open password set, the PDF can only be opened with the password. Once opened, there are no restrictions on what the user can do with the document (for example, print, copy, or change it).
  • With a permissions password set, the PDF can be opened by anyone, but its permissions can be restricted. See Figure 275. After you set a password for permissions, the other choices on the Security page become available.
  • With both the open password and permission password set, the PDF can only be opened with the correct password, and its permissions can be restricted.


Note
Permissions settings are effective only if the user’s PDF viewer respects the settings.
[[Image:|thumb|Figure 275: Security page of PDF Options dialog]]

Figure 276 shows the pop-up dialog displayed when you click the Set open password button on the Security page of the PDF Options dialog.

Exporting to other formats[编辑]

LibreOffice uses the term “export” for some file operations involving a change of file type. If you cannot find what you want under File > Save As, look under File > Export as well.

LibreOffice can export files to XHTML. In addition, Draw and Impress can export to Adobe Flash (.swf) and a range of image formats.

To export to one of these formats, choose File > Export. On the Export dialog, specify a file name for the exported document, then select the required format in the File format list and click the Export button.

[[Image:|thumb|Figure 276: Setting a password to encrypt a PDF]]

E-mailing documents[编辑]

LibreOffice provides several ways to send documents quickly and easily as e-mail attachments in one of three formats: OpenDocument (LibreOffice’s default format), Microsoft Office formats, or PDF.


Note
Documents can only be sent from the LibreOffice menu if a mail profile has been set up in Tools > Options > LibreOffice Writer > Mail Merge E-mail.

To send the current document in OpenDocument format:

  1. Choose File > Send > Document as E-mail. LibreOffice opens your default e-mail program. The document is attached.
  2. In your e-mail program, enter the recipient, subject, and any text you want to add, then send the e-mail.

File > Send > E-mail as OpenDocument Text (or Spreadsheet or Presentation) has the same effect.

If you choose E-mail as Microsoft [Word, Excel, or Powerpoint], LibreOffice first creates a file in one of those formats and then opens your e-mail program with the file attached.

Similarly, if you choose E-mail as PDF, LibreOffice first creates a PDF using your default PDF settings (as when using the Export Directly as PDF toolbar button) and then opens your email program with the .PDF file attached.

E-mailing a document to several recipients[编辑]

To e-mail a document to several recipients, you can use the features in your e-mail program or you can use LibreOffice’s mail merge facilities to extract email addresses from an address book.

You can use LibreOffice’s mail merge to send e-mail in two ways:

  • Use the Mail Merge Wizard to create the document and send it. See Chapter 11, Using Mail Merge, in the Writer Guide for details.
  • Create the document in Writer without using the Wizard, then use the Wizard to send it. This method is described here.

To use the Mail Merge Wizard to send a previously-created Writer document:

  1. Click Tools > Mail Merge Wizard. On the first page of the wizard, select Use the current document and click Next.
[[Image:|thumb|Figure 277: Select starting document]]
  1. On the second page, select E-mail message and click Next.
[[Image:|thumb|Figure 278: Select document type]]
  1. On the third page, click the Select Address List button. Select the required address list (even if only one is shown) and then click OK. (If the address list you need is not shown here, you can click Add to find it and add it to the list.)
[[Image:|thumb|Figure 279: Selecting an address list]]
  1. Back on the Select address list page, click Next. On the Create salutation page, deselect This document should contain a salutation.
[[Image:|thumb|Figure 280: Deselecting a salutation]]
  1. In the left-hand list, click 8. Save, print or send. LibreOffice displays a “Creating documents” message and then displays the Save, print or send page of the Wizard.
  2. Select Send merged document as E-Mail. The lower part of the page changes to show e-mail settings choices.
[[Image:|thumb|Figure 281: Sending a document as an email message]]
  1. Type a subject for your email and click Send documents. LibreOffice sends the e-mails.

Digital signing of documents[编辑]

To sign a document digitally, you need a personal key, also known as a certificate. A personal key is stored on your computer as a combination of a private key, which must be kept secret, and a public key, which you add to your documents when you sign them. You can get a certificate from a certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a kind of checksum is computed from the document’s content plus your personal key. The checksum and your public key are stored together with the document.

When someone later opens the document on any computer with a recent version of LibreOffice, the program will compute the checksum again and compare it with the stored checksum. If both are the same, the program will signal that you see the original, unchanged document. In addition, the program can show you the public key information from the certificate. You can compare the public key with the public key that is published on the web site of the certificate authority. Whenever someone changes something in the document, this change breaks the digital signature.

On Windows operating systems, the Windows features of validating a signature are used. On Solaris and Linux systems, files that are supplied by Thunderbird, Mozilla or Firefox are used. For a more detailed description of how to get and manage a certificate, and signature validation, see “About Digital Signatures” in the LibreOffice Help.

To sign a document:

  1. Choose File > Digital Signatures.
  2. If you have not saved the document since the last change, a message box appears. Click Yes to save the file.
  3. After saving, you see the Digital Signatures dialog. Click Add to add a public key to the document.
  4. In the Select Certificate dialog, select your certificate and click OK.
  5. You see again the Digital Signatures dialog, where you can add more certificates if you want. Click OK to add the public key to the saved file.

A signed document shows an icon in the status bar. You can double-click the icon to view the certificate.

Removing personal data[编辑]

You may wish to ensure that personal data, versions, notes, hidden information, or recorded changes are removed from files before you send them to other people or create PDFs from them.

In Tools > Options > LibreOffice > Security > Options, you can set LibreOffice to remind (warn) you when files contain certain information and remove personal information automatically on saving.

To remove personal and some other data from a file, go to File > Properties. On the General tab, uncheck Apply user data and then click the Reset button. This removes any names in the created and modified fields, deletes the modification and printing dates, and resets the editing time to zero, the creation date to the current date and time, and the version number to 1.

To remove version information, either (a) go to File > Versions, select the versions from the list and click Delete; or (b) use File > Save As and save the file with a different name.