LibreOffice 3.4入门/Draw入门

维基教科书,自由的教学读本
跳到导航 跳到搜索

目录

What is Draw? 什么是Draw[编辑]

Draw是一个矢量图形绘制程序,同时也可对一些栅格图像(点阵)进行操作。通过Draw,用户可快速创建多种图型。 Draw is a vector graphics drawing program, although it can also perform some operations on raster graphics (pixels). Using Draw, you can quickly create a wide variety of graphical images.

与用点阵(屏幕上的点)表示的栅格图不同。在矢量图中,图像的内容以简单的几何元素(如直线、圆和多边形)进行存储和显示。矢量图像易于存储,在显示时也方便对图像进行拉伸。 Vector graphics store and display an image as simple geometric elements such as lines, circles, and polygons rather than a collections of pixels (points on the screen). Vector graphics allow for easier storage and scaling of the image.

Draw已经完整的集成进LibreOffice办公套件中,这样就可在套件的不同组件之间方便的交换图像。举例来说,如果用户在Draw中创建了一幅图片,只需复制粘贴即可在Writer中重用这幅图片。用户也可通过Draw的子功能和工具在Writer或Impress中直接使用绘图功能。 Draw is fully integrated into the LibreOffice suite, and this simplifies exchanging graphics with all components of the suite. For example, if you create an image in Draw, reusing it in a Writer document is as simple as copying and pasting the image. You can also work with drawings directly from within Writer or Impress, using a subset of the functions and tools from Draw.

尽管Draw无法与高端图像处理程序相媲美,但与其他办公软件中集成的绘图工具相比,Draw的功能更为强大。 Draw’s functionality is extensive; even though it was not designed to rival high-end graphics applications, it possesses more functions than most drawing tools that are integrated with office productivity suites.

下面是Draw程序的一些绘制功能: A few examples of drawing functions are:

  • 图层管理
  • 磁性网格点系统
  • 尺寸和测量显示
  • 用于组织图的连接符
  • 3D功能,用于绘制小型三维物体(含有纹理和光照效果)
  • 绘制和页面样式一体化
  • 贝塞尔曲线
  • Layer management
  • Magnetic grid point system
  • Dimensions and measurement display
  • Connectors for making organization charts
  • 3D functions that enable small three-dimensional drawings to be created (with texture and lighting effects)
  • Drawing and page style integration
  • Bézier curves

本章介绍一些Draw特性,但不会面面俱到。如果想获得更多关于Draw的信息,参见Draw Guide和LibreOffice程序中的帮助。 This chapter introduces some of Draw’s features, but it does not attempt to cover all of them. See the Draw Guide and the application Help for more information.

The Draw workspace Draw工作区[编辑]

Draw工作区的主要部分如图161所示。 The main components of the Draw workspace are shown in Figure 161.

用户可在绘图区域的周围放置工具栏和信息提示区。根据工作需要的不同,用户可通过首选项定制可见工具的数目和位置。因此,您的界面和图中的布局可能有些不同。例如:许多人將主要绘图工具放在工作区的左边,而非下方。 You can surround the drawing area with toolbars and information areas. The number and position of the visible tools vary with the task in hand and user preferences. Therefore, your setup may look different. For example, many users put the main Drawing toolbar on the left-hand side of the workspace, not at the bottom as shown here.

用户可将Draw 的绘图区分割成多页,多页绘图主要在简报中使用, You can split drawings in Draw over several pages. Multipage drawings are used mainly for presentations. The Pages pane, on the left side of the Draw window in Figure 161 gives an overview of the pages that you create. If the Pages pane is not visible on your setup, you can enable it from the View menu (View > Page Pane).

[[Image:|thumb|Figure 161. Initial Draw window]]

Rulers[编辑]

[[Image:|thumb|Figure 162: Rulers show the size of the selected object]]You should see rulers (bars with numbers) on the upper and left-hand side of the workspace. The rulers show the size of a selected object on the page (see the gray double lines, highlighted in Figure 177Figure 162). When no object is selected, they show the location of the mouse pointer, which helps to accurately position drawing objects more accurately.

[[Image:|thumb|Figure 163. Ruler units]]You can also use the rulers to manage object handles and guide lines, making it easier to position objects. The page margins in the drawing area are also represented on the rulers. You can change the margins directly on the rulers by dragging them with the mouse.

To modify the unit of measurement of a ruler, right-click on the ruler and select one of the measurement units. The two rulers can have different units.

Status bar[编辑]

The Status bar is located at the bottom of the screen in all LibreOffice components; it includes several Draw-specific fields.

For details on the contents and use of these fields, see Chapter 1, Introducing LibreOffice, in this book and Chapter 1, Introducing Draw, in the Draw Guide.


Note
The sizes are given in the current measurement unit (not to be confused with the ruler units). This unit is defined in Tools > Options > LibreOffice Draw > General, where you can also change the scale of the page. Another way to change the scale is to double-click on the number shown in the status bar.
[[Image:|thumb|Figure 164: Left end of the Draw status bar]]
[[Image:|thumb|Figure 165: Right end of Draw status bar]]

Toolbars[编辑]

To display or hide the various Draw toolbars. choose View > Toolbars. On the menu that appears, select which toolbars you want to display. For more about working with toolbars, see Chapter 1, Introducing LibreOffice, in this book.

The tools available in the Draw toolbars are explained in the following sections. The appearance of the toolbar icons may vary depending on your operating system and the selection of icon size and style in Tools > Options > LibreOffice > View.

Standard toolbar

The Standard toolbar is the same for all LibreOffice components and is not described in detail in this chapter.

[[Image:]]

Line and Filling toolbar

The Line and Filling toolbar lets you modify the main properties of a drawing object. See page 194 for details.

[[Image:]]

Text Formatting toolbar

If the selected object is text, the toolbar changes to the Text Formatting toolbar, which is similar to the Formatting toolbar in Writer. For more information, see Chapter 4, Getting Started with Writer, in this book.

[[Image:]]

Drawing toolbar

The Drawing toolbar is the most important toolbar in Draw. It contains all the necessary functions for drawing various geometric and freehand shapes and for organizing them on the page.

[[Image:]]

Options toolbar

Use the Options toolbar to activate or deactivate various drawing aids. To display the Options toolbar, select View > Toolbars > Options.

[[Image:|thumb|Figure 166: Options toolbar]]

Choosing and defining colors[编辑]

Color Bar

To display the Color Bar, use View > Toolbars > Color Bar. The toolbar then appears at the bottom of the workspace.

[[Image:]]

This toolbar lets you rapidly choose the color of the objects in your drawing. The first box in the panel corresponds to transparency (no color).

You can access several specialized color palettes in Draw, as well as change individual colors to your own taste. To do this, choose Format > Area or the pouring can icon on the Line and Filling toolbar. This opens the Area dialog. Choose the Colors tab (Figure 167).

To load another palette, click on the Load Color List button (circled). The file selector dialog asks you to choose one of the standard LibreOffice palettes (files with the file extension *.soc). For example, web.soc is a color palette that is particularly adapted to creating drawings that are going to appear in Web pages. The colors will correctly display on workstations with screens displaying at least 256 colors.

The color selection box also lets you individually change any color by modifying the numerical values in the fields provided to the right of the color palette. You can use the color schemes known as CMYK (Cyan, Magenta, Yellow, Black), and RGB (Red, Green, Blue).

Click on the Edit button to open the Color dialog, where you can set individual colors. See “Color options” in Chapter 2, Setting Up LibreOffice, of this book. Many more input possibilities are available in this dialog.

For a more detailed description of color palettes and their options, see Chapter 8, Tips and Tricks, in the Draw Guide.

[[Image:|thumb|Figure 167. Changing the color palette]]

Positioning objects with snap functions[编辑]

In Draw, objects can be accurately and consistently positioned using grid points, special snap points and lines, object frames, individual points on objects, or page edges. This function is known as Snap.

The snap function is easier to work with at the highest practical zoom value. You can use two different snap functions at the same time, for example snapping to a guide line and to the page edge. It is best, however, to activate only those functions that you really need.

This section summaries the snap-to-grid function. For more detailed information about the snap functions, see Chapter 8, Tips and Tricks, and Chapter 10, Advanced Draw Techniques, in the Draw Guide.

Snap to grid[编辑]

Use this function to move an object exactly to a grid point (see Figure 168). This function can be switched on and off with View > Grid > Snap to Grid and on the Options toolbar with the [[Image:]] icon.

[[Image:|thumb|Figure 168: Exact positioning with snap to grid]]

Showing the grid[编辑]

To make the grid visible, choose View > Grid > Display Grid. Alternatively, turn the grid on (or off) with the [[Image:]] icon on the Options toolbar.

Configuring the grid[编辑]

The color, spacing, and resolution of the grid points can be individually chosen for each axis. The spacing between the lines is defined in the Grid options dialog (Tools > Options > LibreOffice Draw > Grid).

[[Image:|thumb|Figure 169: Setting grid options]]

In the dialog shown in Figure 169, you can set the following parameters:

  • Vertical and horizontal spacing of the dots in the grid. You can also change the unit of measurement used in the general Draw options (Tools > Options > LibreOffice Draw > General).
  • The resolution is the size of the squares or rectangles in the grid. If the resolution is Horizontal 1 cm, Vertical 2 cm, the grid consists of rectangles 2 cm high and 1 cm wide.
  • Subdivisions are additional points that appear along the sides of each rectangle or square in the grid. Objects snap to subdivisions as well as to the corners of the grid.
  • The pixel size of the snap area defines how close you need to bring an object to a snap point or line before it will snap to it.

Changing the color of the grid points[编辑]

The default grid dots are light gray, which can be hard to see. To change the color of the grid points, choose Tools > Options > LibreOffice > Appearance.

[[Image:|thumb|Figure 170: Changing the grid color]]

In the Drawing / Presentation section, you can change the color of the grid points. On the Color Settings pulldown menu, select a more suitable/visible color, for example black.

Positioning objects with guiding lines[编辑]

To simplify the positioning of objects it is possible to make visible guiding lines—extensions of the edges of the object—while it is being moved. These guiding lines have no snap function.

The guiding lines can be activated or deactivated under Tools > Options > LibreOffice Draw > View > Guides when moving, or by clicking on the [[Image:]] icon on the Options toolbar.

The basic drawing shapes[编辑]

Draw provides a wide range of shapes, located in palettes accessed from the Drawing Toolbar. This section describes only a few of the basic shapes. These shapes include; rectangles and squares, circles, ellipses, and arcs, 3D objects, curves, lines and arrows, text, and connectors. All shapes in Draw are called objects. See the Draw Guide for a complete description of the shapes available.


Note
When you draw a basic shape or select one for editing, the Info field at the left side in the status bar changes to reflect the present action: Line created, Text frame xxyy selected, and so on.

Figure 171 shows part of the Drawing toolbar with the icons needed in the following sections. The Text icon is also included.

[[Image:|thumb|Figure 171: Part of the Drawing toolbar]]

Drawing a straight line[编辑]

Click on the Line icon [[Image:]] on the Drawing toolbar and position the mouse pointer where you want to start the line. Drag the mouse while keeping the button pressed. Release the mouse button at the point where you want to end the line.

A selection handle appears at each end of the line, showing that this is the currently selected object.

[[Image:|thumb|Figure 172: Drawing a straight line]]

To restrict the angle of the line to a multiple of 45 degrees (0, 45, 90, 135, and so on), hold down the Shift key while you draw the line.

To snap the end of the line to the nearest grid point, hold down the Control (Ctrl) key while drawing the line.


Note
The effect of the Ctrl key depends on the settings of the Snap to Grid option on the View > Grid menu:Snap to Grid on: Ctrl deactivates the snap option for this activity.Snap to Grid off: Ctrl activates the snap option for this activity.

To extend the line symmetrically in both directions from the starting point, hold down the Alt key while drawing the line.

To change line attributes (for example, the color or line type), select the line by clicking on it, then use the tools in the Line and Filling toolbar; or for more control, right-click on the line and choose Line to open the Line dialog.

Drawing an arrow[编辑]

Arrows are drawn like lines. Draw classifies arrows as a subgroup of lines: Lines with arrowheads. The information field on the status bar shows them only as lines. Click on the Line Ends with Arrow icon [[Image:]] to draw an arrow.

Choosing line endings[编辑]

Several types of line endings (arrows, circles, squares, and others) are available in Draw. Choose View > Toolbars > Arrows, or click on the small black triangle on the Lines and Arrows [[Image:]] icon on the Drawing toolbar, to open a toolbar with ten tools for drawing lines and arrows. The last-used command is stored on the toolbar to make it quicker to call it up again.

[[Image:|thumb|Figure 173: Arrows toolbar]]

Drawing a rectangle or square[编辑]

Drawing a rectangle is similar to drawing a straight line, except that you click on the Rectangle icon [[Image:]] from the Drawing toolbar, and the (imaginary) line drawn by the mouse corresponds to a diagonal of the rectangle. The rectangle changes shape as you drag the mouse around.

[[Image:|thumb|Figure 174: Drawing a rectangle]]

Hold down the Shift key to draw a square. Hold down the Alt key to draw a rectangle starting from its center. To combine the effects, hold down both the Shift and Alt keys simultaneously.

Drawing a circle or ellipse[编辑]

To draw an ellipse (also called an oval) or a circle, use the Ellipse icon [[Image:]] from the Drawing toolbar. (A circle is simply an ellipse with both axes the same length.) The ellipse drawn is the largest ellipse that fits inside the (imaginary) rectangle drawn with the mouse.

[[Image:|thumb|Figure 175: Drawing an ellipse]]

Here are some other ways to draw an ellipse or circle:

  • To draw a circle, hold down the Shift key while dragging the mouse.
  • To draw an ellipse with the starting point at the center (instead of the corner), hold down the Alt key while dragging the mouse.
  • To draw a circle with the starting point at the center, hold down both the Alt and Shift keys while dragging the mouse.
  • To draw an ellipse or circle that snaps to the nearest grid points, hold down the Ctrl key while dragging the mouse.


Note
If you first press and hold down the Ctrl key and then click on one of the icons for Line, Rectangle, Ellipse, or Text, a standard sized object is drawn automatically in the work area; the size, shape, and color are all standard values. These attributes can be changed later, if desired.

Drawing curves[编辑]

The tools for drawing curves or polygons are on the toolbar that appears when you click arrow next to the Curve icon [[Image:]] on the Drawing toolbar. This toolbar contains eight tools (see Figure 176).

If you move the mouse cursor over one of the icons, a tooltip pops up with a description of the function.


Note
Hovering the mouse pointer over this icon gives a tooltip of Curve. If you convert the icon to a floating toolbar, however, the title is Lines, as shown in Figure 176.
[[Image:|thumb|Figure 176: Curves toolbar (incorrectly titled "Lines")]]

Polygons

Draw the first line from the start point with the left mouse button held down. As soon as you release the mouse button, a first corner point is drawn; move the mouse to see how the second line will look. Every mouse click sets another corner point. A double-click ends the drawing. A filled polygon automatically joins the last point to the first point to close off the figure and fills it with the current standard fill color. A polygon without filling will not be closed at the end of the drawing.

Polygon 45°

Like ordinary polygons, these are formed from lines but with angles of 45 or 90 degrees between them.

Freeform line

With this tool you can draw just like with a pencil. Press and hold the left mouse button and drag the mouse. It is not necessary to end the drawing with a double-click. Just release the mouse button and the drawing is completed. If you have selected Freeform Line, Filled, the end point is joined automatically to the start point and the object is filled with the appropriate color.

Curves and filled curves

For a description of the handling of curves and filled curves, see Chapter 10, Advanced Draw Techniques, in the Draw Guide.

Writing text[编辑]

Use the Text tool [[Image:]] to write text and select the font, color, size, and other attributes. Click at the location where you want to position the text or click and drag to create a larger text frame. Press Enter to move the cursor to the next line.

When you have finished typing text, click outside the text frame. Double-click on the text at any time to edit it.

When you use the Text tool, the Text formatting toolbar is visible; it includes the usual paragraph attributes: indents, first line, and tab stops.

You can create Graphics styles that you can reuse for other text frames. Select Format > Styles and Formatting or press F11 to open the Styles and Formatting window. Graphics styles affect all of the text within a text frame. To style parts of the text, use direct formatting with the toolbar.

Text frames can also have fill colors, shadows, and other attributes, just like any other Draw object. You can rotate the frame and write the text at any angle. These options are available by right-clicking on the object.

Use the Callout tool [[Image:]], located on the Drawing toolbar, to create callouts (also known as captions or figure labels).

If you double-click on an object or press F2 (or the Text icon in the Drawing toolbar) when an object is selected, text is written in the center of the object and remains within the object. Nearly any kind of object contains such an additional text element. These texts have slight differences to those in text frames concerning position and hyphenation.

For more about text, see Chapter 2, Drawing Basic Shapes, and Chapter 10, Advanced Draw Techniques, in the Draw Guide.

Gluepoints and connectors[编辑]

All Draw objects have associated invisible gluepoints, which become visible when you choose any of the connectors under the Connector icon [[Image:]] on the Drawing toolbar and then move the mouse pointer over the object.

Most objects have four gluepoints, as shown in Figure 175. You can add more gluepoints, and customize gluepoints, using the toolbar under the Gluepoint icon [[Image:]] on the Drawing toolbar.

[[Image:|thumb|Figure 177: Four gluepoints]]

Gluepoints are different from handles (the small blue or green squares around an object). The handles are for moving or resizing an object. The gluepoints attach connectors to an object.

Connectors are lines or arrows whose ends automatically dock to gluepoints on an object. When you move the other object, the connector moves with it. Connectors are particularly useful for making organizational charts. You can reorganize the blocks of your chart and all the connected objects stay connected.

Figure 178 shows two Draw objects and a connector.

[[Image:|thumb|
Figure 178: A connector between two objects
]]

Draw offers a range of different connectors and connector functions. Open the floating Connector toolbar by clicking on the arrow next to the Connector icon [[Image:]]. For more about connectors and gluepoints, see Chapter 9, Organization Charts, Flow Diagrams, and More, in the Draw Guide.

Drawing geometric shapes[编辑]

Geometric shapes include basic shapes, symbol shapes, block arrows, flowcharts, callouts, and stars.

Figure 179 shows part of the Drawing toolbar with the icons referred to in the following sections. Clicking on the arrow next to the icon opens a floating toolbar with the relevant work tools.


Tip
The use of all these tools is similar to that of the Rectangle tool, even though they produce different geometric shapes.
[[Image:|thumb|Figure 179: Part of the main Drawing toolbar]]

Basic shapes


The Basic Shapes icon [[Image:]] makes available the range of tools for drawing basic shapes, including a rectangular tool identical to the one on the main toolbar.

The only differences you will see are in the information field in the status bar (in this case, “shape selected” rather than “Rectangle selected”).

[[Image:]]

Symbol shapes


The Symbol Shapes icon [[Image:]] provides an array of tools for drawing the various symbols.
[[Image:]]

Block arrows


The Block Arrows icon [[Image:]] opens the Block Arrows toolbar.
[[Image:]]

Flowcharts


The tools for drawing flowcharts are accessed by clicking on the Flowcharts icon [[Image:]].

The creation of flowcharts, organization charts, and similar planning tools are described in Chapter 9, Organization Charts, Flow Diagrams, and More, in the Draw Guide.

[[Image:]]

Callouts


Use the Callouts icon [[Image:]] to open the Callouts toolbar.
[[Image:]]

Stars and banners


These tools are associated with the Stars icon [[Image:]].
[[Image:]]

You can add text to all these shapes. See Chapter 2, Drawing Basic Shapes, and Chapter 10, Advanced Draw Techniques, in the Draw Guide for details.

Selecting objects[编辑]

Direct selection[编辑]

To easiest way to select an object is to click directly on it. For objects that are not filled, click directly on the object’s outline to select it.


=== Selection by framing ===

You can select several objects at once by using the mouse to drag a large rectangle around the objects, as shown. For this to work, the Select [[Image:]] icon on the Drawing toolbar must be active. Only objects that lie entirely within the rectangle are selected.

[[Image:]]

Selecting hidden objects[编辑]

Even if objects are located behind others and not visible, they can still be selected. Hold down the Alt key and click where the object is located. If there are several overlapping objects, hold down the Alt key and click until you reach the object you want. To cycle through the objects in reverse order, hold down the Alt+Shift keys. The number and type of selected objects is shown at the left of the status bar to help you select the correct object.


Note
This method generally works in Windows, but on a Linux system it usually does not. If the Alt key on your system does not operate as described above, use the Tab key method described below.

To select an object that is covered by another object using the keyboard, press the Tab key to cycle through the objects, stopping at the object you wish to select. To cycle through the objects in reverse order, press Shift+Tab. This may not be practical if you have a large number of objects in your drawing.


When you click on the selected object, its outline will appear briefly through the objects covering it.

In the illustration to the right, the square located beneath the circle was selected in this way (the circle was made transparent in order to see the square).

[[Image:]]

Arranging objects[编辑]

In a complex drawing, several objects may be stacked on top of one another. To rearrange the stacking order (move an object to the front or to the back of the stack), select the object, choose Modify > Arrange and choose Bring Forward or Send Backward. Or right-click the object, choose Arrange from the context menu, then choose Bring Forward or Send Backward.

These options are also available from the Arrange tear-off toolbar from the [[Image:]] button on the Drawing toolbar. A keyboard shortcut is Shift+Ctrl+plus sign to bring an object to the top, and Shift+Ctrl+minus to send an object to the bottom.

Draw also provides tools for aligning multiple objects; details are given in the Draw Guide.

Selecting several objects[编辑]

To select or deselect several objects one by one, press the Shift key and click on the various objects to be selected or deselected. One click on an object selects it; a second click on the same object deselects it.

Moving and dynamically adjusting an object’s size[编辑]

There are several ways of moving or changing the size of an object. The dynamic method described here uses the mouse.

When you dynamically change an object, remember to check the left-hand area of the status bar at the bottom of the Draw window. This area shows detailed information about the ongoing manipulation. This information changes when the mouse is moved.

Dynamic movement of objects[编辑]

To move an object, select it and then click within the object’s border and hold down the left mouse button while dragging the mouse.

During movement, the shape of the object appears a faded version of the shape to help with repositioning.

To drop the object at its new location, release the mouse button. The new position appears immediately in the Status Bar.

[[Image:]]

Dynamic size modification of objects[编辑]

To change the size of a selected object (or group of selected objects) with the mouse, move one of the handles located around the selection. As shown in the following illustration, a faded version of the new object shape is shown.
[[Image:]]

The results depend on which handle you use. To resize an object along one axis, use the appropriate side handle. To resize both axes, use a corner handle. The new size appears immediately in the status bar.


Note
If you press the Shift key while resizing an object, the change in size will be carried out symmetrically with respect to the two axes, so that the aspect (height/length) ratio of the object remains the same.

Rotation[编辑]

Rotating an object lets you move the object around an axis. To do this dynamically (with the mouse), use the red handles, as you do when changing the size of the object.


Note
Rotation works in a slightly different way for 3D objects because the rotation occurs in 3D space and not in one plane. See Chapter 7, Working with 3D Objects, in the Draw Guide regarding rotation when Edit Points mode is active.

To rotate an object (or a group of objects), drag the red corner handle point of the selection with the mouse. The mouse cursor takes the shape of an arc of a circle with an arrow at each end. A faded version of the object being rotated appears and the current angle of rotation is dynamically shown in the status bar.

Rotations are made around an axis which is displayed as a small symbol, as shown in Figure 180. You can move the axis of rotation with the mouse.

If you hold down the Shift key during the rotation, the operation will be carried out in increments of 15°.

[[Image:|thumb|Figure 180: Rotating an object]]

Inclination and perspective[编辑]

To slant or shear objects, use the red handles located at the midpoint of an edge of the selected objects. The mouse pointer changes to a [[Image:]] when the pointer hovers over one of these midpoint handles. Not every object can be slanted; basic shapes can be rotated but not slanted.


The slant axis is the point directly opposite the midpoint handle to be used for shearing the object. This point stays fixed in location; the other sides and edges move in relation to it as the mouse is dragged (make sure that the [[Image:]] handle icon is showing before dragging).

As with rotation, you can set the inclination (slanting) to occur in steps of 15° by pressing the Shift key while moving the handle.

Editing objects[编辑]

To change an object’s attributes (such as color and border width) you can use the Line and Filling toolbar or the context menu.

If the Line and Filling toolbar (Figure 181) is not visible, you can display it using View > Toolbars > Line and Filling. From here you can edit the most common object attributes. You can also open the Line dialog by clicking on the Line [[Image:]] icon and the Area dialog by clicking on the Area [[Image:]] icon to see more options.


[[Image:]]
1 Styles and Formatting

2 Line

3 Arrow Style

4 Line Style

5 Line Width

6 Line Color

7 Area

8–9 Area Style / Filling

10 Shadow

Figure 181: Line and Filling toolbar

When you select text, this toolbar changes to show text formatting options.

The context menu[编辑]

When an object is selected, you can right-click on the object to bring up a context menu, which provides additional access to the options shown above and another way to change an object’s attributes. The entries with a small arrow on the right-hand side contain a submenu.

Editing lines and borders[编辑]

Lines, arrows, and the borders of an object are managed through the Line dialog. An object’s border is just another type of line.
[[Image:]]

You can change some properties from the Line and Filling toolbar. To see more options, select the object and click on the Line [[Image:]] icon or right-click on the object and choose Line from the context menu. This opens the Line dialog.

Common line properties[编辑]

In most cases the property you want to change is the line’s style (solid, dashed, invisible, and so on), its color, or its width. These options are all available from the Line and Filling toolbar (Figure 181).

You can also edit these properties from the Line dialog, where you can also change the line’s transparency. Figure 182 illustrates different degrees of transparency.

Figure 182: The vertical lines have different levels of transparency (0%, 25%, and 50%).

[[Image:]]Drawing arrows[编辑]

Arrowheads (and other line endings—usually referred to collectively as arrows) are a line property. Select a line and click on the Arrow Style [[Image:]] icon from the Line and Filling toolbar. This opens the Arrowheads menu.

Several types of arrowheads are available. Each end of the line can have a different arrowhead (or no arrowhead).

Arrowheads are only applicable to lines. They have no effect on an object’s border.

Customizing line and arrow styles[编辑]

You can modify the line and arrow styles and create your own. See Chapter 4, Changing Object Attributes, in the Draw Guide for details.

Editing the inside (fill) of an object[编辑]

The LibreOffice term for the inside of an object is Area fill. The area fill of an object can be a uniform color, a gradient, a hatching, or an image. It can be made partly or fully transparent and can throw a shadow.

[[Image:]]

In most cases, you will choose one of the standard fill options, which are all available from the Line and Filling toolbar. You can also define your own area fills; see Chapter 4 of the Draw Guide for details.

Adding a shadow[编辑]

In Draw, shadows are considered as an area property. Click on the Shadow [[Image:]] icon on the Line and Filling toolbar.

You can customize the position, distance, color, and transparency of shadows by using Format > Area > Shadow or by right-clicking on the selected object and choosing Area > Shadow.

[[Image:]]

Adding transparency[编辑]

You can make objects partly or fully transparent, or even with a varying degree of transparency (as a gradient).

Using styles[编辑]

Suppose that you want to apply the same area fill, line thickness, and border to a set of objects. This repetitive process can be greatly simplified by the use of styles. Styles allow you to define a formatting template (a style) and then to apply that style to multiple objects. For more information about styles, see Chapter 3, Using Styles and Templates, in this book.

Special effects[编辑]

With Draw, you can apply many special effects to objects and groups of objects. This section describes a few of these effects. More effects include distorting, shadows, and transparency can be found in Chapter 4, Changing Object Attributes, of the Draw Guide.

Flip an object[编辑]

Select an object and click on the Flip icon [[Image:]]. You will see a dashed line through the middle of the object.
[[Image:]]
This dashed line is the axis of symmetry. The object will be flipped around this line. Move one or both ends of the line with your mouse to set the orientation of the axis.
[[Image:]]
Then, grab any one of the eight green handles and move it across to the other side of the dashed line. The new position of the figure is shown dashed until the mouse is released.
[[Image:]]
Note
If you hold down the Shift key while moving the line, the line will rotate in 45-degree increments.

Mirror copies[编辑]

Move the axis of symmetry to the desired location of the mirror axis. Copy the object to the clipboard. Flip the object, then click on an empty area of the Draw screen in order to deselect the object. Paste from the clipboard to put a copy of the object in its original location and now you have a mirror copy.


[[Image:]]
[[Image:]]

Distorting an image[编辑]

There are three tools on the Effects menu that let you drag the corners and edges of an object to distort the image.

The Distort tool distorts an object in perspective, the Set to Circle (slant) and Set in Circle (perspective) tools both create a pseudo three-dimensional effect. See Chapter 4 of the Draw Guide for details.

Dynamic gradients[编辑]

You can control transparency gradients in the same manner as color gradients. Both types of gradient can be used together. With a transparency gradient, the direction and degree of an object’s fill color changes from opaque to transparent (in a regular gradient, the fill changes from one color to another, but the degree of transparency remains the same). See Chapter 4 of the Draw Guide for details.

Duplication[编辑]

Duplication makes copies of an object while applying a set of changes (such as color or rotation) to the duplicates. The result of a duplication is a new group of objects.

To start duplication, click on an object or group and choose Edit > Duplicate. The dialog shown in Figure 184 appears. When the options chosen in that dialog are applied to a blue rectangle, they produce the result shown in Figure 183.

[[Image:|thumb|Figure 183: Result of duplication]]
[[Image:|thumb|Figure 184: Duplicating an object]]

Cross-fading[编辑]

Cross-fading transforms a shape from one form to another. The result is a new group of objects including the start and end points and the intermediate steps.

To carry out a cross-fade, first select two objects (hold the Shift key while selecting each object in turn) and then choose Edit > Cross-fading.

On the Cross-fading dialog, choose the number of increments (transition steps). You probably want to have Cross-fade attributes and Same orientation both checked. The end result is shown in Figure 186.

[[Image:|thumb|Figure 185: Choosing cross-fading settings]]
Figure 186: Cross-fading example

Combining multiple objects[编辑]

Using Draw, you can combine drawing objects together in two distinct ways: grouping and combining. These two methods allow you to treat multiple objects as one unit, or to merge objects to form a new shape.

Grouping is like putting objects in a container. You can move them as a group and apply global changes to them. A group can always be undone and the objects that make up the group can always be manipulated separately.

A combination is a permanent fusion of objects leading to a new object. The original objects are no longer available as individual entities and the operation is not reversible.

Grouping by common selection[编辑]

When several objects are selected, any operations you carry out are applied to all of the objects. For example, you can rotate a group of objects in its entirety. Groups obtained through common selection of several objects are undone as soon as you click outside the group. However, you can group objects and keep those selected objects grouped together.

Maintaining groups and undoing groups[编辑]

To group objects, first select the objects, then right-click and choose Group from the pop-up menu. You can also use the keyboard shortcut Ctrl+Shift+G or choose Modify > Group from the menu bar.

When objects are grouped, any editing operations carried out on that group are applied to all members of the group. If you click on one member of the group, the whole group is selected.

The objects of a group retain their own individual properties. To undo a group, right-click and choose Ungroup from the pop-up menu, use the keyboard shortcut Ctrl+Alt+Shift+G or choose Modify > Ungroup from the menu bar.

You can edit a member of a group individually without breaking the group. To do this, right-click and choose Enter group or double-click on the group.

Combining objects[编辑]

In contrast to grouping functions, combinations create a new object; subsequent “un-combining” in the same manner as ungrouping is not possible. Select a collection of objects, then right-click and choose Combine from the pop-up menu.

After you have selected more than one object, the Merge, Subtract, and Intersect functions can be reached in the Modify > Shapes menu or though the group’s right-click menu under the heading Shapes.

Aids for positioning objects[编辑]

Draw has various tools to help you arrange the objects with respect to each other:

  • Moving an object to the front or to the back
  • Aligning objects with respect to each other
  • Distributing the distance and space between objects

See Chapter 5, Combining Multiple Objects, in the Draw Guide for more information.

Inserting and editing pictures[编辑]

Draw contains a number of functions for editing raster graphics (bitmaps)—for example, photos and scanned images—including import and and export as well as conversion from one format to another. Draw can read in all the usual range of graphic file formats.

You can add pictures from several sources:

  • The Gallery—see Chapter 11, Graphics, the Gallery, and Fontwork
  • Directly from a scanner (Insert > Picture > Scan)
  • Images created by another program, including photographs from a digitial camera (Insert > Picture > From File)

Draw provides tools for working with bitmap images: the Picture toolbar and the bitmap image management palette. However, it does not have the same capabilities as the specialized raster graphics programs like Adobe Photoshop or The Gimp. See Chapter 6, Editing Pictures, in the Draw Guide for details and examples.

Working with 3D objects[编辑]

Although Draw does not match the functionality of the leading drawing or picture editing programs, it is capable of producing and editing very good 3D drawings.

Draw offers two types of 3D objects: 3D bodies, and 3D shapes. Depending on which type you choose, there are different possibilities for further editing of the object (rotation, illumination, perspective). 3D shapes are simpler to set up and edit than 3D bodies, but 3D bodies currently allow for more customization.

See Chapter 7, Working with 3D Objects, in the Draw Guide for details.

Exporting graphics[编辑]

To save a Draw image in a format other than *.odg, use File > Export. Draw can save to many graphic file formats, as listed in Appendix B of this book. You can export the entire file or selected objects.

You can also export Draw files to HTML, PDF, or Flash. PDF export is the same as for any part of LibreOffice, as described in Chapter 10, Printing, Exporting, and E-mailing, of this book. Flash export creates a .swf file.

HTML export uses a conversion wizard that creates as many web pages as there are pages in your Draw document. You can optionally choose to display the pages in frames with a navigator and can set an index page. For more information, see Chapter 12, Creating Web Pages: Saving Documents as HTML Files, of this book.

Adding comments to a drawing[编辑]

Draw supports comments similar to those in Writer and Calc.

Choose Insert > Comment from the menu bar. A small box containing your initials appears in the upper left-hand corner of the Draw page, with a larger text box beside it. Draw has automatically added your name and the date at the bottom of this text box.

Type or paste your comment into the text box. You can optionally apply some basic formatting to parts of the text by selecting it, right-clicking, and choosing from the pop-up menu. From this menu, you can also delete the current comment, all the comments from the same author, or all the comments in the document.

You can move the small comment markers to anywhere you wish on the page. Typically you might place it on or near an object you refer to in the comment.

To show or hide the comment markers, choose View > Comments.

[[Image:]]

Choose Tools > Options > User Data to enter the name you want to appear in the Author field of the comment.

If more than one person edits the document, each author is automatically allocated a different background color.