Android/模擬器

維基教科書,自由的教學讀本
跳至導覽 跳至搜尋

在開始創建模擬器之前,您需要搭建好Android開發環境,並至少擁有一個Android Platform。

Android Platform[編輯]

Android從最初的1.0到最新的4.1,已經推出了數十個版本。由於很多設備並不能升級到最新版本,還有些設備更適合於早期版本,用戶的Android設備可能具有非常多不同的版本。據2012年的統計,Android2.2設備數量最多,Android2.2以上版本佔據了所有Android設備的97%以上。

每一代Android作業系統都有新的特性和較為重大的改進,為此在新的Android作業系統平台上必須使用新的開發平台。因此,隨著新Android系統發布,Android SDK都會升級,同時增加一個最新的Android Platform。

一個或多個版本的Android作業系統對應一個Android Platform,這取決於他們是否有相同的API。Android向下兼容新平台兼容舊平台,反之則不可以。也就是說Android2.2應用程式可以在Android2.3,4.0,4.1版本上運行,而Android4.1應用程式卻不能保證可以在Android2.2上運行。

在安裝Android模擬器之前,必須要安裝對應版本的Android Platform。可打開Android SDK Manager安裝相應版本。

創建模擬器[編輯]

Android4.1[編輯]

Android是目前最新的Android版本。

打開Android SDK Manager,檢查你是否已經安裝了Android4.1目錄下面的:

  • SDK Platform
  • Documentation for Android SDK
  • ARM EABI v7a System Image或者其他Image中任選其一
Android SDK Manager 20 install Android 4.1.png

安裝完成後關閉Android SDK Manager,打開Android Virtual Device Manager。打開New,新建一個模擬器。設置Name,Target,CPU/ABI等屬性。點擊Creat AVD創建完成。

你可以忽略一些可選設置選項,如SD卡,屏幕尺寸,附加特性等。這些特性都可以在創建完成後修改。

Android2.2[編輯]

打開Android SDK Manager,檢查你是否已經安裝了Android2.2目錄下面的:

  • SDK Platform

以及在最新的Android4.1中的:

  • Documentation for Android SDK

注意:在新版SDK中,所有Android平台使用同一個文檔。

安裝完成後關閉Android SDK Manager,打開Android Virtual Device Manager。打開New,新建一個模擬器。設置Name,Target,CPU/ABI等屬性。Name不能包含空格;Target選擇Android版本,如Android4.1;CPU/ABI選擇硬體平台類型。點擊Creat AVD創建完成。

可以忽略一些可選設置選項,如SD卡,屏幕尺寸,附加特性等。這些特性都可以在創建完成後修改。

修改模擬器[編輯]

FAQ[編輯]