LibreOffice 3.4入门/使用样式和模板

维基教科书,自由的教学读本
跳到导航 跳到搜索

什么是模板?[编辑]

所谓模板就是您用来创建其他文档的模型。例如,您可以创建一个首页含有您公司Logo的模板,将其用于商业报告,那么基于该模板创建的所有文档,在它的首页上都有您的公司Logo。

模板可以包含任何普通文档可以包含的东西,如文本、图形、一套样式集及用户指定的设置信息(含度量单位、语言、默认打印机和菜单与工具栏的定制信息等)等。

在LibreOffice,所有的文档都是基于模板创建的。您可以为任何类型的文档(文本、电子数据表、图形和电子演示稿)创建一个指定的模板。如果在启动一个新文档时,您没有指定模板,那么该文档将会基于该文档类型的默认模板创建。如果您没有指定默认模板,那么LibreOffice将使用该文档类型在LibreOffice系统自带的空白模板。更多详细信息,请参考“设置默认的模板”。

什么是样式?[编辑]

所谓样式就是一组相关元素的格式集合,您可以应用这个格式集合可以快速地修改所选的页面、文本、边框和其他元素的外观。当您在应用某个样式时,您是同时应用一整套格式的组合。

很多人习惯手动对段落、文字、表格、页面版式和文档中的其他部分进行格式设置,却对从未关注过“样式”。他们习惯于根据“物理属性”来编写文档,比如您可能会指定文档的字体、字体大小和其他任何格式(像倾斜与加粗)。

样式是“逻辑”属性。如您使用样式,意味着您停止使用“字体大小14pt、宋体、加粗、居中”的手动方式,而是开始直接使用“标题”样式,因为您已经定义好了符合“标题”特征的样式。换句话讲,样式的使用意味着让您把重心从文本(页面或其他元素)的外观转到了文本的内容。

样式可以帮助改善文档的连贯性,也使文档主体格式修改变得更为便捷。例如,当您需要对一个很长的文档的整个段落的缩进程度进行修改,或者对所有的标题的字体进行修改时,这个原本简单的操作却变得很困难,而样式的使用就能使之变得更为便捷。

此外,在LibreOffice中,很多操作都使用到了“样式”,甚至您自己都没有察觉到它的使用。例如,Writer在生成目录时就要使用到标题样式(或者其他您指定的样式)。一些常见的样式使用案例请参考“样式使用的范例

LibreOffice支持下列几种样式:

  • 页面样式,包括页边距、页眉(又名首页)和页脚、边框和背景等。在Calc里,页面样式也包括工作表页面打印顺序。
  • 段落样式控制着段落外观的所有表现方式。比如,文本对齐方式、制表位(制表符停止位)、间距和边框及其他的字符格式。
  • 字符样式会影响段落中选取文字的格式,如字体、字体大小、粗体及斜体等格式。
  • 框架样式是用来格式化图形及文本的边框,包括环绕方式、边框、背景及框线等。
  • 列表样式(项目符号和编号):用来设置项目符号和编号列表的对齐方式、编号和项目符号的类型、字体等。
  • 单元格样式包括字体、对齐方式、边框、背景、数字的格式(例如货币、日期、数字等)和单元格保护等。
  • 图形样式,是在Draw与Impress中独有的样式,它包括绘图与演示文稿(幻灯片)的线条、区域(格式菜单里显示为“平面”)、阴影、透明度、字体、连接符、尺寸及其他属性的格式设置。
  • 演示文稿样式,也是在Draw与Impress中独有的样式,包括字体、缩进、间距、对齐方式和标签等。

不同的LireOffice的应用程序拥有不同的样式,见表2。

LibreOffice自带了很多预定义的样式,您可以LibreOffice系统中提供的样式,也修改它们或创建新的样式,就如本章所述。

表2.不同的LibreOffice的软件中拥有的样式
样式类别 Writer Calc Draw Impress
页面样式
段落格式
字符样式
框架样式
项目符号与编号(列表)样式
单元格样式
演示文稿样式
图形样式 (已包含在框架样式)

使用样式[编辑]

LibreOffice提供了几种使用样式的方式,您可以选择任意一种方式。

使用样式和格式窗口[编辑]

第一步:单击位于格式工具栏最左边的“样式和格式”图标,或单击菜单“格式 > 样式和格式”,或按快捷键"F11",就会弹出“样式和格式窗口”。该窗口显示了当前使用的LibreOffice软件(Writer,Calc,draw、Impress)中使用的样式类型。

您可以把该窗口移动到屏幕的其他位置,或者把它固定到边上(按住Ctrl键不放,放置鼠标到标题栏,然后把它拖到要固定的位置)。

第二步:单击“样式与格式”窗口左上方的任意一个图标,窗口下方则会出現指定类別的样式集。
第三步:若要使用当前文件中已有的样式(除了字符样式),把插入光标放到使用样式的段落、框架或页面上,然后双击样式列表中某个样式。若要使用字符样式,则先要选中相关的字符。
提示
在样式与格式窗口底部有一个下列式列表。如图47 窗口中显示“自动”,表示样式列表里仅包含了LibreOffice自动使用的样式。您可以选择显示所有的样式或某个组的样式,比如仅显示自定义样式。


使用填充格式模式[编辑]

使用填充格式模式可以迅速地对大量的不同区域进行样式填充,而不必每次都返回到“样式与格式”窗口下使用双击。当您需要用同一样式对许多分散的段落、单元格和其他元素格式化时,这种方法非常有用。

其具体步骤如下:

第一步:打开“样式与格式窗口”,然后选择您要使用的样式。
第二步:单击“填充格式模式”图标。[此处缺少图片示例]。
第三步:若您要使用段落、页面或框架样式,把鼠标放到该段落、页面或框架,然后单击。若要使用字符样式,在选中文字(字符)后,按住鼠标左键不放,然后单击该文字(字符)来应用样式。重复做第三步直到您使用该样式套用了所有的样式。
第四步:若您要退出“填充格式模式”,再次单击“填充格式模式”图标,或按“Esc”键即可。
警告
当这个模式被启动以后,右击文档的任何地方都会撤消最近的一次填充操作。当心!不要因为偶然使用的右击,导致您想保留的填充被撤消。

使用样式列表[编辑]

当您在文档中使用某种样式以后,该样式的名称就会显示在格式工具栏最左边的“使用样式列表框”(在“样式与格式”图标旁边)。

若您要使用该样式,打开这个列表框以后,然后单击一次您要的样式,或者您可以在列表框中移动“UP”与"Down"箭头键,然后按“Enter”键来应用列表里高亮显示的样式。

提示
您还可以单击“使用样式列表”中的“更多”来打开“样式与格式窗口”。
[[Image:|thumb|
Figure 48: The Apply Style list on the Formatting toolbar
]]

使用快捷键[编辑]

有些快捷键被预定义为应用某种样式。例如,在Writer ,"Ctrl+0"是使用“正文”样式,“Ctrl+1”就使用“标题1”样式和“Ctrl+2”则是使用“标题2”样式。您可以修改这些快捷键,然后创建您自己的快捷键,相关介绍请参考请第十四章定制LibreOffice

警告
如果文档中使用了手动格式(也叫做“直接格式”)替代“样式”,那么这时您就不能通过使用某种样式来清除手动格式。若要清除手动格式(直接格式),选中文本,右击鼠标,然在弹出式菜单中选择“清除直接格式”。

修改样式[编辑]

LibreOffice提供了下列几种方式来修改样式(包括预定义样式和任何一种您创建自定义的样式):

  • 使用“样式对话框”来修改样式。
  • 从选项中更新样式。
  • 使用自动更新(只限段落和框架样式)。
  • 从另一个文档或模板中导入或复制样式。
提示
您对样式作出任何更改仅对当前文档有效。若您要修改不止一个文档的样式,就需要如“复制与转移样式”所述,修改模板或把样式复制到其他文档,请查看复制与转移样式

使用“样式对话框”修改样式[编辑]

若您要修改“样式对话框”里原有的样式,请在“样式与格式窗口”里,右击您需要的样式,然后从弹出式菜单里选择“修改”

“样式对话框”所显示的样式取决您选中的样式类型。每个样式对话框都有几个标签页。详情请参考用户里有关样式的章节。

从选项中更新样式[编辑]

从选项中更新样式的步骤是:

第一步: 打开“样式与格式窗口”。
第二步:然后在文档中,选择含有您希望采纳为样式且已格式化的元素。
警告
确保段落上有特殊的属性(格式)。例如,如果有两套不同字体大小或字体样式,特定属性(格式)将会保持与以前一样,即无法采纳为样式。
第三步:在“样式与格式窗口”中,选择您要更新的样式(注:单击,不是双击),然后单击“选中的新样式”按钮旁边的箭状图标(小三角形),再找到“更新样式”并单击。
[[Image:|thumb|Figure 49: Updating a style from a selection]]

使用自动更新[编辑]

自动更新仅适用于段落与框架格式。如果在“段落样式或框架样式”编辑对话框中的“自动更新”选项被选中,那么在文档对段落或框架所使用的直接格式都会对相应的样式进行自动更新。

提示
如果您习惯手动更新样式,请勿选中此项。

从文档或模板中更新样式[编辑]

您可以更新样式通过复制或载入它们从一个模板或另外一个文档。请参考“复制和转移样式

创建自定义样式[编辑]

若您想要添加一些新的样式,有两种方式:

  • 通过“样式对话框”创建新的样式
  • 从选取的样式图标中创建新的样式

通过“样式对话框”创建新的样式[编辑]

若要通过“样式对话框”创建新样式,在“样式与格式窗口”里面右击,然后从弹出的菜单里选择“新建”;若要从原有的样式中创建您的样式,首先选该样式,然后右击再选择“新建”

若使用了“链接到”某种样式的功能,当您更改了基础样式(例如,把字体从宋体改为微软雅黑)时,所有“链接到的样式”也会随之改变。

“定义新样式”与“修改原有样式的对话框”的选项类似,详情请请参考用户使用指南中有关样式的章节。

从选取的样式图标创建样式[编辑]

您可以通过复制一个直接格式(手动格式)来创建新样式,但这个新建的样式仅对当前文档有效,也不会保存到模板中。步骤如下:

第一步:打开样式与格式窗口,然后选择您要创建的样式类型。
第二步:在文档中,选择您想保存为样式的格式。
第三步:在样式与格式窗口中,单击“选中的新样式”图标。
第四步:在“创建样式”对话框里,输入新样式的名称。列表中上显示的都已有的该类型的自定义样式。
[[Image:|thumb|Figure 50: Naming a new style created from a selection]]

使用拖动创建样式[编辑]

警告
此项功能在LibreOffice3.6以后无效!

You can drag and drop a text selection into the Styles and Formatting window to create a new style.

Writer

Select some text and drag it to the Styles and Formatting window. If Paragraph Styles are active, the paragraph style will be added to the list. If Character Styles are active, the character style will be added to the list.

Calc

Drag a cell selection to the Styles and Formatting window to create cell styles.

Draw/Impress

Select and drag drawing objects to the Styles and Formatting window to create graphics styles.

复制和转移样式[编辑]

若您想要把样式从“一个模板或文档”复制或转移到“另一个模板或文档”,有两种方式:

  • 使用模板管理对话框
  • 从模板或文档中载入样式

使用模板管理对话框[编辑]

使用“模板管理对话框”来复制或转移样式的步骤:

第一步:单击菜单“文件 > 模板 > 管理”
第二步:在“模板管理对话框”里,见图51,根据您需要来设置对话框底部的模板或文档,默认左边是模板,右边是文档。
说明
若要把样式从未打开的文档中复制出来,单击“文件”按钮,找到您要的文件。当您返回到原对话框时,两个列表都会显示选中的文件与当前打开的文档。
第三步:打开文件夹,然后找到您要复制的源与目标模板。双击“源模板或者文档”名,然后在“模板或文档名”下面,双击“样式”图标来显示样式列 表清单。
第四步:若您要复制其中某个样式,按住“Ctrl”不放,然后使用鼠标把样式名从其中一个列表拖到另一个列表。
警告
如果您在拖动时没有同时按住“Ctrl”,那么样式会从一个列表转移到另一个列表而不是复制,而且这个被拖动的样式将会从原样式列表中删除。
  • 第五步:重复第四步多次直到复制完所有您要的样式。如果您接收样式的“模板或文档”本身含有太多的样式,您可能看不到任何更变除非您打开向下列表。当您完成后,单击“关闭”
[[Image:|thumb|Figure 52: Copying a style from one document to another]]

从模板或文档中载入样式[编辑]

您可以从模板或另一个文档中复制样式,具体步骤如下:

第一步:打开您要把样式复制到里面的文档。
第二步:在“样式与格式窗口”中,单击“选择新的样式”图标旁边的箭头(向下的三角形),然后单击“加载样式”(见图49)
第三步:在“装入样式”对话框中(见图53),找到并选择您要从里面复制样式的模板。
[[Image:|thumb|Figure 53. Copying styles from a template into the open document]]
第四步:再选择您要复制的样式类别,如果您希望您复制的样式来替代任何同名的样式,请选择“改写”。
第五步:单击“确定”复制样式,而在屏幕却看不到任何更改。
说明
若您要从另一个文档中复制样式,单击“从文件”按钮来打开您需要选的文档窗口。
警告
如果您的文档中含有内容目录,而您又想定制“标题”样式,而“标题”的级别与“章节编号”有关(在“工具 > 章节编号”),那么在“样式”载入后,它们的样式将变回默认的样式,如标题1,标题2等。这时您就需要手动地改回您要的样式。

删除样式[编辑]

任何LibreOffice系统原有样式,即使是那些没有使用的,您都不能从一个文档或模板中删除。

您可以删除任何用户自定义样式,但在此之前,您要确保该样式没有在当前文档中使用。如果不想要的样式仍在使用中,你应该找一个替代样式,而不是删除样式。

若您要删除不想要的样式,在“样式与格式”窗口上右击(一次只能删除一个)该样式,然后在弹出式菜单上单击“删除”

若该样式正在使用,您将会收到一条警告消息。

说明
在删除样式之前,一定要确保该样式没有正在使用。否则,所有使用该样式的对象都会变成系统默认样式,然后它们的格式都会保留为直接格式(手动格式)。

若样式没有正在使用,在删除时,您就会收到一条确认消息,单击“确定”就可以删除该样式。

用模板创建文档[编辑]

若您要使用模板来创建一个文档,其步骤如下:

第一步:从主菜单中,选择“文件 > 新建 > 模板及文档”,打开“模板及文档对话框”。
第二步:在对话框的左侧,单击“模板”图标(如果未被选取),在中央的框里将会显示模板文件夹。
第三步:双击包含需要的模板的文件夹,在该文件夹里的模板将会显示在中央的框里。
第四步:选择需要的模板,您可以预览该模板或者查看该模板的属性。要预览模板,单击“预览”图标。右边就会出现要预览的模板。
第五步:单击打开,此时“模板与文档对话框”就会关闭。然后在LibreOffice中就会一个基于选中的模板创建的文档。接下来,您可以编辑,然后像操作其他文档一样保存这个该文档。
[[Image:|thumb|Figure 54: Templates and Documents dialog]]

创建模板[编辑]

您有两种方式创建您自己的模板:从文档中创建,或使用向导创建。

从文档创建模板[编辑]

从文档中创建模板的步骤如下:

第一步:创建一个新的文件,或者打开一个已有的文件(文本文档(odt)、电子表格文件、演示文稿等)。
第二步:添加内容及样式。
第三步:从主菜单中,选择“文件 > 模板 >保存”,此时就会打开“模板对话框”。
[[Image:|thumb|Figure 55: Saving a new template]]
第四步:在对框话的“新建模板”输入框中,输入新模板的名称。
第五步:在“分类”列表中,单击您为该模板指定的分类。您选择的模板分类对模板本身不产生任何影响;它仅仅是您保存模板的文件夹,而为模板选择一个恰当的“分类”,将便于使用时查找。例如,您可能会把幻灯片模板保存在“演示文稿”分类下。

想了解更多有关模板文件夹信息,请参见“模板的管理”。

第六步:单击“确定”以保存新模板。

对文档做任何一项“新增或修改”的设置,它都可以保存到模板。下面就列举了一些可以保存在Writer文档中(不是完整列表)设置,然后另存为模板供日后使用。

  • 打印机设置:哪种打印机,双面或单面打印,纸张大小等。
  • 使用过的样式:包括字符、页面、框架、项目编号和段落样式等。
  • 索引、目录、参考文献、表格等格式及设置。

模板也可以包含预设定的文本,它可以节省您新建文档时输入该内容的时间。例如,信的模板就要含有您的姓名、地址、问候语。

您也可以在模板中保存菜单栏与工具栏的定制,更多详情请参见“定制LibreOffice”。

使用向导创建模板[编辑]

您可以使用“向导”来为信函、传真、会议议程、演示文稿、网页等创建模板。

举个例子,传真向导通过以下选项来指引您:

  • 传真的类型(商务传真或私人传真)
  • 文档中包含的项目像日期、主题行(商务传真)、称呼和结束语等。
  • 发件人与收件人的信息(商务传真)。
  • 在页脚中要包含的信息(商务传真)。

通过向导创建模板的步骤:

第一步:从主菜单中,选择“文件 > 向导”[您需要的模板类型].
[[Image:|thumb|Figure 56. Creating a template using a wizard]]
第二步:跟着向导进行相关操作,这个过程对不同的类型的模板有所不同,但其风格类似。
第三步:在向导的最后一步,您可以为每种类型的模板指定名称及保存路径。默认的保存路径是您的模板文件目录,但您也可以选择另一个不同的位置。
第四步:最后,您现在就可以创建一个新的文档,或手动地修改模板。此时,对于以后创建的文档,您就重新使用由该向导创建的模板,就如您使用其他模板一样。

编辑模板[编辑]

您可以编辑模板的样式与内容,然后对由该模板建立的文档重新应用该模板的样式(注:您只能改变样式,不能修改内容)。

编辑模板的步骤如下:

第一步:从菜单栏上,选择“文件 > 模板 > 编辑”,将会打开一个标准的文件浏览器。
第二步:选择并打开您要编辑的模板。
第三步:编辑模板,就如您编辑其他文档一样。若您要保存您的修改,从主菜单上,选择“文件 > 保存”

通过修改模板来更新文档[编辑]

由于模板经过编辑修改,下一次当你打开由该模板建立的文档时,将会出现下列消息。

[[Image:|thumb|Figure 57. Update styles message]]

单击“更新样式”来应用模板样式更改到文档,若您不想应用模板的样式更改到文档,请单击“保留原有样式”

警告
如果您在消息框中选择“保留原有样式”(见图57),那么下一次您打开“基于更改的模板”创建的文档时,这条消息框将不会再次显示。您就不会再有另一个机会“从模板中更新样式”,当然您可以通过宏命令重新打开这个特性,请参见如下备注:
说明
要重新打开从模板中更新样式这一功能,步骤如下:

第一步:使用菜单栏“工具 > 宏 > 管理宏 >LibreOffice Basic ”,从列表中选取文档,单击扩展符号(+或三角形),然后选择“Standard”。如果“Standard”旁边还有一个扩展符号,单击它,然后选择一个Module。

第二步:如果“编辑”按钮是可用的,请单击它;用如果不可用,单击“新建”

第三步:在“Basic”窗口,输入下列代码:

Sub FixDocV3

set UpdateFromTemplate

oDocSettings = ThisComponent.createInstance( _  "com.sun.star.document.Settings" )

oDocSettings.UpdateFromTemplate = True 

End  Sub FixDocV3

第四步:单击运行BASIC图标,然后关闭文档。

第五步:保存文档。

下一次当您打开这个文档时,您又会被提示从更改的模板中更新样式。

从他处获取模板[编辑]

您可以从许多地方下载LibreOffice模板,包括官方的模板仓库 http://templates.libreoffice.org/,然后安装到您的电脑上。在其他的网站上,您能会找到打包好的模板集扩展(.OXT)文件。

安装单个模板[编辑]

安装个人的模板的步骤如下:

第一步:下载模板,然后保存到您的电脑上。
第二步:将模板导入到模板文件夹中,请参考导入模板的相关章节。
提示
(对于高级用户)如果您知道LibreOffice的模板文件夹所在位置,您还可以手动地把新模板复制到里面,其具体位置取决于您的电脑的操作系统。要了解模板文件夹的保存位置,请选择“工具 > 选项 > 路径”

通过扩展管理器来安装模板集[编辑]

扩展管理器提供了一种简单的办法来安装打包好的模板集扩展,步骤如下:

第一步:下列扩展包(.OXT文件),然后保存到您的电脑硬盘上。
第二步:在LibreOffice,从菜单上选择“工具 > 扩展管理器”。在扩展管理器里,单击“添加”来打开文件浏览窗口。
第三步:找到并选择您要安装的扩展包,然后单击“打开”。模板包开始安装,您也许会被要求接受某个协议。
第四步:当安装完成时,模板就可以通过“文件 > 新建 >模板与文档”,然后您可以在扩展管理里看到该扩展。
[[Image:|thumb|
Figure 58: Newly-added package of templates]]

有关扩展管理器,请参考第十四章定制LibreOffice

设置默认模板[编辑]

如果您通过从主菜单栏上选择“文件 > 新建 > 文本文档”(或电子表格、演示文稿、绘图)来创建一个文档,那么LibreOffice将通过该类型的默认模板来创建文档。然后,您也可以设置一个定制的模板作为默认模板,稍后也可以重置为系统默认。

说明
仅对Microsoft Windows用户:

您可能知道Micosoft Word有一个normal.docm文件作为它的默认模板及如何更新它。而LibreOffice却没有一个类似的默认模板文件,“默认出厂设置”已经嵌入到软件里。

设置定制模板为默认[编辑]

只要是在“模板管理”对话框里任意一个文件夹显示的模板,您都可以设为默认。

若要设置一个定制的模板为默认,步骤如下:

第一步:从主菜单上,选择“文件 > 模板 > 管理”,打开模板管理对话框。
第二步:在左边的选框中,选择含有您要设置为默认模板的文件夹,然后选择模板。
第三步:单击“命令”按钮,然后从弹出菜单里选择“设置成默认模板”。

在您下一次通过“文件 > 新建”来创建文档时,该文档就会基于这个模板创建。

[[Image:|thumb|Figure 59: Setting a default template using the Template Management dialog]]

虽然许多重要的设置可以在选项对话框里更改(参见第2章),例如默认的字体与页面大小,更多高级设置(如页边距)只能通过替换默认模板来更改。

重置为系统默认模板[编辑]

若您要把某种文档类型默认模板重置为LibreOffice系统默认模板,其步骤如下:

第一步:在“模板管理”对话框,单击左边的任何一个文件夹。
第二步:单击“命令”按钮,然后从弹出菜单里选择“重置默认模板”。除非某个定制的模板已经被设置为系统默认(见上一节),是不会出现这个选项。

在您下一次通过“文件 > 新建”来创建文档时,该文档的创建就会基于该类型的系统默认模板。

用另一个模板来关联文档[编辑]

在有些情况下,您可能需要把文档与另外一个模板相关联,或者编辑一个不是由模板创建的文档。

使用模板的最大优势就在于可以更加便捷地对多个文档进行样式更新,正如本章开头所述。但当您想通过使用另一个模板的样式来更新文档时,这时由于文档将与另一个模板没有任何样式上的关联,这样就行不通,您就需要把文档与另一个模板相关联。另外,当文档不是基于模板创建的时,您就也需要把该文档与另一个模板相关联。

您有两种方式来完成二者的关联。两种方式都要求原有文档的样式名称与新模板的样式名称二者最好一样,如果不同,您就需要通过使用“编辑 > 查找& 替换 ”把原有的样式替换成新的样式,更多有关使用“查找与替换”来替换样式的详情,请参见第4章Writer入门。

方式1

如果使用这种方式,模板中会存在许多图形与文本(如法律声明)及它们的样式,如果您不需要这些材料,请删除。

第一步:从菜单栏上,选择“文件 > 新建 > 模板与文档”。然后选择您需要的模板,如果模板中含有您不需要的文本或图形,删除它们。
第二步:打开您要修改的文档(它将在一个新窗口中打开)。按“CTRL+A”来全选整个文档,复制,然后粘贴到第一步中创建的空白文档中。
第三步:如果有目录,请更新目录,然后保存文件。

方式2(仅适用于Writer)

说明
此方式要安装插件,由于官方文档并未说明插件位置。

若使用这种方式,新模板就会不有任何的图形与文本,除了一些页眉与页脚材料。它仅仅包含一些新模板的样式,用来建立模板与文档之间的关联。 第一步:打开那些您要修改的文档,选择“文件 > 模板”

说明
In Writer, if you do not see Assign Template (current document) or Assign Template (folder) under File > Templates, you need to download the Template Changer extension from http://extensions.libreoffice.org/ and install it as described on page 66. Then close and reopen LibreOffice to activate the extension.

In Calc, Impress, and Draw, only the Assign Template (folder) choice is available when the extension is installed.

模板的管理[编辑]

LibreOffice只能使用LibreOffice模板文件夹里的模板,但您也可以建立新的LibreOffice模板文件夹,然后用来管理您的模板。例如,您也许有一个文件夹放置报告模板,另一个用来放置书信模板。另外您也可以导入及导出模板。

若您要开始,请从主菜单栏上选择“文件 > 模板 > 管理”,打开“模板管理”对话框。(见图55)

说明
模板管理器上的命令按钮的所有操作,都可以右击模板或文件夹实现。
提示
LibreOffice的模板文件夹位置与您的电脑的操作系统有关。想要了解模板文件夹在您的电脑的位置,请打开“工具 > 选项 > LibreOffice >路径”。

新建模板文件夹[编辑]

若要新建一个模板文件夹,其步骤如下:

第一步:在模板管理对话框里,单击任意一个文件夹。
第二步:单击“命令”按钮,然后从弹出式菜单上选择“新建”,将有一个名称叫“未命名”的新文件夹出现。
第三步:输入新文件夹的名称,然后按“Enter”,LibreOffice将会以您输入的名称保存该文件夹。

删除模板文件夹[编辑]

您删除不了由LibreOffice系统自带的与扩展管理器安装的模板文件夹;您只能删除由您自己创建的模板文件夹。

若要删除一个由您自己建立的模板文件夹,步骤如下:

第一步:在模板管理对话框里,选择您要删除的文件夹。
第二步:单击“命令”,然后从弹出的菜单里选择“删除”,这时就会显示一个消息框,请您确认删除,单击“是”

移动模板[编辑]

若要从一个模板文件夹移动一个模板到另一个模板文件夹,步骤如下:

第一步:在模板管理对话框里,双击含有您要移动的模板的文件夹。
第二步:单击您要移动的模板,然后把它拖到目标文件夹。如果您没有从源文件夹删除模板的权限,这个操作将会变成复制而不是移动。

删除模板[编辑]

您删除不了由LibreOffice系统自带的与扩展管理器安装的模板;您只能删除由您自己创建或导入的模板。

删除模板的步骤如下:

第一步:在模板管理对话框里,双击含有您要删除的模板的文件夹。
第二步:单击您要删除的模板。
第三步:单击“命令”,然后从弹出的菜单里选择“删除”,这时就会显示一个消息框,请您确认删除,单击“是”

导入模板[编辑]

如果您要使用的模板在另外的文件夹里,这时就需要把它导入到LibreOffice的模板文件夹。

导入模板到模板文件夹的步骤如下:

第一步:在模板管理对话框里,选择您要放置导入模板的文件夹。
第二步:单击“命令”按钮,然后从弹出的菜单里选择“导入模板”,这时将会打开一个标准的文件浏览器窗口。
第三步:找到并选择您要导入的模板,然后单击“打开”。这时文件浏览器窗口将会关闭,该模板就会出现选取的文件夹里。
第四步:如果您需要,请输入该的名称,然后按“Enter”键。

导出模板[编辑]

从模板文件夹里把模板导出到另一个文件夹的步骤如下:

第一步:在模板管理对话框里,双击含有您要导出的模板的文件夹,然后该文件夹中包含的所有模板都列出在它下面。
第二步:单击您要导入的模板。
第三步:单击“命令”按钮,然后从弹出的菜单里选择“导出模板”,将会弹出另存为窗口。
第四步:找到您要把模板导出的文件夹,然后单击“保存”。

打印模板或文档中定义的样式清单[编辑]

打印模板中定义的样式的步骤如下:

第一步:在模板管理对话框里,双击含有模板的文件夹。
第二步:双击您需要的模板,样式就会在它下面出现,单击“样式”来选取它。
第三步:单击“命令”按钮,然后从弹出的菜单里选择“打印”,将会弹出打印对话框。从对话框里,

您可以把它打印到文件或打印机。更多详情有关打印对话框,请参考第10章。

[[Image:|thumb|Figure 60: Printing a list of styles in a template]]

提示
要打印文档中的样式清单,双击模板管理对话框中间列的文档名称,然后就会显示“样式”,然后使用“命令 > 打印”。

样式使用的范例[编辑]

下列是在Writer中常见的页面与段落样式使用范例,也有许多种其他的方式使用样式,请参考其他应用程序的入门指南。

设计文档首页[编辑]

许多文档,比如书信与报告,有一个与其他页面不同的首页。例如,信的首页通常是有一个不同的页眉,或报告的首页通常是没有页眉与页脚,而其他页面却有。在LibreOffice,您可以为首页定义“页面样式”,然后为下面的页面自动地指定样式。

我们可以使用LibreOffice自带的“首页”与“默认”页面样式为例,图61就显示我们想要的结果:首页后面接的是默认页面,然后首页后面所有的页面都使用默认页面样式。详情请参考第4章Writer入门中的“格式化页面”。

[[Image:|thumb|Figure 61: Flow of page styles]]

分割文档章节[编辑]

类似的方式,您可以分割一个文档为不同的章节。每一章都以首页样式开头,后面的页面则使用默认样式,正如上节所述。在每章的末尾,插入一个手动分页符,并指定首页样式来开始下一个章节。

[[Image:|thumb|Figure 62: Dividing a document into chapters using page styles]]

更改页面方向[编辑]

一个Writer文档(.odt文本文档)可以包含不同方向的页面。常见的情况是在文档中间含有一个横向页面,而其他是纵向页面。这也可以通过分页符与页面样式来完成。

不同左右页眉[编辑]

页面版式可以设置为左右对称,或者只有右页(章节的首页往往被定义为右页),或者只有左页。当插入页眉到页面版式为左右对称或左右相同的页面时,您可以使所有的页面有相同的页眉,或者左右页面不同。例如,您可以把左页的页码放在左边而右页的页码放在右边,或者只在右页显示文档标题,及其他的更改。

自动页面分割[编辑]

Writer可以自动地把它的文本从一页分割到下一页。如果您不喜欢默认的设置,您可以修改它们。例如,您需要由一个图形来开启一个新页面或行,并指定新页面的样式。典型的做法是章节标题总是从右页(单数)页面开始。

自动生成目录[编辑]

若您要自动生成目录,第一步就是使用标题样式格式化您想出现在目录中的内容,然后使用“工具 > 章节编号”来告诉Writer目录中的哪一级标题使用哪一种样式。详情请参见第4章。

定义样式序列[编辑]

您可以设置一个段落样式,然后当您在段落最后按下“Enter”键时,该段落就会自动套用您想要的样式。例如,您可以定义一个“标题1”段落,其次一个“正文”段落。更为复杂的例子是:标题、作者、摘要、标题1、正文。设置这个序列,您就可以避免手动地修改大量使用样式。