LibreOffice 3.4入门/LibreOffice设置

维基教科书,自由的教学读本
跳到导航 跳到搜索

为所有LibreOffice组件选择选项[编辑]

这一节涵盖了一些适用于所有LibreOffice组件的通用设置。这里没有提到的设置信息,可以从LibreOffice在线帮助中获取。

单击 工具 > 选项。 左侧方框中的选项列表——LibreOffice对话框会随着打开的LibreOffice组件不同而发生变化。此章的插图展示的是Writer中打开的选项列表。

单击对话框中LibreOffice左侧的标记(可能是加号,三角形或其他,这与操作系统有关),之后子列表会向下展开。选择其中一个项,会引起对话框右侧显示内容的变化。

图19 LibreOffice选项
说明
右下角的返回按钮,对于所有LibreOffice选项都有相同的效果。它将选项重置到上一次保存的设置,从上一次保存到按下返回按钮之间进行的所有设置都将失效。

用户数据选项[编辑]

因为LibreOffice使用存储在LibreOffice-用户数据页中的名字、公司等个人信息做某些用途,包括文档属性(创建者,最后编辑者信息)和批注更改的作者的名字,你需要确保这里信息是正确的。

填写图20中的表单,添加,修改或删除其中的信息,使之完整正确。在开始使用LibreOffice之前,这是首要的工作。

针对不同语言地区的LibreOffice版本,字段标签也可能会不同。中文版的设置和英文版设置有较大区别。

图20 填写用户数据

一般选项[编辑]

LibreOffice - 一般页上的选项如下图所示。

图21 为LibreOffice设置一般选项

帮助 - 提示

提示被激活时,当你将鼠标指针放到界面上的图标或某个区域上,会出现一些提示词语。

帮助 - 扩展提示

扩展提示被激活时,当你将鼠标指针放到界面上的图标,菜单,或是某个区域上,会出现一段简短的功能描述。

帮助 - 帮助助理

若要关闭帮助助理(类似于 Microsoft Office 助手),取消此选项。要重置默认行为,单击重置帮助助理

打开/保存对话框 - 使用LibreOffice对话框

要使用操作系统的标准“打开/保存”对话框,取消此选项。若此选项被选中,LibreOffice提供的打开/保存对话框将会启用。第一章 LibreOffice 简介中有更详细的介绍。本教科书中插图将使用LibreOffice的打开/保存对话框。这能够在不同操作系统之间保持一致性。

打开/保存对话框 - 首先显示 ODMA DMS 对话框

(仅适用于Windows)如果你在电脑中安装了GroupWise客户端,你可以选择此选项,使用LibreOffice.org提供的服务在GroupWise上打开或保存文件。如果GroupWise客户端没有被安装,此选项无效。

打印对话框 - 使用LibreOffice对话框

(仅适用于Mac)要使用操作系统的标准打印对话框,取消此选项。若此选项被选中,LibreOffice提供的打印对话框将会启用。本教科书在插图中使用LibreOffice打印对话框。

文档状态 - 打印时设置成“文档已修改”状态

若此选项被选中,下一次打印后,打印日期将被记录到文档属性中。因此你将会被提醒保存更改,即使你没有修改文档。

文档状态 - 即使文档未改动也允许保存文档

通常若一个文档在创建或上次保存后没有被修改,文件 > 保存 菜单项和标准工具栏上的保存图标都是无效的,Ctrl+S也没有效果。选择此选项允许文档即使没有被修改,也能够保存。

年份(两位数字)

指定如何解释两位数的年份。例如,如果两位数年份被设置为1930~2029的100年,当你输入一个两位数年份,或者读取两位数年份30,则会被解释为1930年,而非1830年或2030年;若两位数年份为20,则会被解释为2020年。

启用实验性(不稳定的)功能

要尝试LibreOffice 3.4中的两项实验性功能:行内公式编辑(可在公式内部输入,并通过光标键查看周边内容)及宏录制功能,可选择此项。

内存选项[编辑]

在选项对话框中,单击 LibreOffice > 内存。这些选项控制LibreOffice使用计算机内存的方式和需要多少内存。在修改它们之前,你需要考虑以下几点:

  • 更多的内存能使LibreOffice更快更流畅(比如,更多内存能够支持更多撤销步数);但是副作用就是,其它应用程序可用的内存就更少了,您可能会耗尽内存。
  • 如果您的文档包含很多对象,比如图片,视频或其它大对象,增加LibreOffice程序的内存或者每个对象的内存,LibreOffice的性能会提升。如果您发现一些对象似乎从文档中消失了,不妨在缓存中增加对象的数量。(对象依旧存在于文档中,即使您不能看到它们;它们没有足够的缓存以显示自己)
  • 为了在您启动计算机时就加载“快速启动”程序(一个在桌面或者系统托盘中的图标),选内存择选项对话框底部的快速启动选项。这使得LibreOffice启动更快;弊端是LibreOffice消耗更多的内存,即使不使用的时候。此选项(在GNU/Linux中被称为“启用系统托盘快速启动器”)在Mac OS X中不可用,在其它没有安装此附加组件的系统中也不可用。
图22 为LibreOffice选择内存选项

视图选项[编辑]

LibreOffice > 视图 页上的选项影响文档窗口的视觉效果和行为方式。一些选项在下面将做具体介绍。设置这些选项以符合您的个人喜好。

图23 为LibreOffice选择视图选项

用户界面 – 显示比例

如果帮助文件或者LibreOffice界面菜单中的文本看起来太小或太大,您可以修改缩放比例来调整它的显示大小。有时修改缩放比例会带来不确定的结果,这取决于您系统中可用的屏幕字体。这并不会影响您文档中文本实际的字体大小。

用户界面 – 图标大小和样式

第一个框指定工具栏图标的显示大小(自动,小,或大)。“自动”图标大小选项使用您的操作系统默认值。(在Windows 7中默认是小图标,而在Gnome桌面环境中默认是大图标)大图标更便于定位,而小图标节约空间,您可以根据屏幕大小和操作习惯来选择尺寸。第二个框指定图标样式(主题);“自动”图标样式选项使用和您的操作系统、桌面环境兼容的图标集(在Windows和Gnome中是Tango,而在Ubuntu中则是Human)。
警告
不同的操作系统或桌面环境中的LibreOffice可能使用不同的图标集,这很大程度上会影响您阅读本书,尤其是当寻找某个工具栏按钮的时候。本书将使用Tango(探戈,有时被误翻译为“糖果”)图标集,它是LibreOffice在Windows和Gnome桌面环境中默认的图表集合。LibreOffice在Ubuntu中的默认图标集是Human,而在KDE桌面环境中则是Galaxy(银河)。为了更方便地阅读本教科书,您不妨将图标集改为Tango(探戈)。

用户界面 – 将系统字体用于用户界面

如果您想使用系统字体(您的电脑操作系统的默认字体)来替代LibreOffice为用户界面提供的字体,请选中该项。

用户界面 – 平滑屏幕字体边缘

选中该项将平滑屏幕字体边缘外观,然而再输入您要平滑的最小字体的像素尺寸。
说明
该选项在Windows操作系统中不可用,因此不会在图23所示的对话框中显示此选项。在Windows操作系统中,LibreOffice不能平滑屏幕字体边缘。

菜单 – 菜单中的图标

此选项会影响菜单样上的图标与文字的显示方式。

字体列表 - 显示字体预览

图24:有预览(左)和无预览(右)的字体列表
选中此项会使字体列表外观如图24左侧所示,使字体名以字体样式显示;当此项未选中时,字体列表仅显示字体名,而不显示它们的格式(见图24右侧)。字体列表里的字体,即是您安装在系统里的字体。
选中此项后,那些需要串连起来使用的字体,如阿拉伯文、希伯来文、马拉雅拉姆文等,会额外出现一个以该文字显示的示例文本。而中文字体末尾会有“简”“繁”标记。

字体列表 - 显示字体历史

选中此项后,您在当前文档最后选择的五种字体,将会显示在字体列表框的顶部。否则,这些字体就会以标准字母表顺序显示。

图形输出 – 使用硬件加速

直接通过硬件特性(图形显示卡)增强图形输出效果。
说明
不是所有的操作系统和LibreOffice发行版都能支持此功能。

图形输出 – 使用抗锯齿

开启或者停用抗锯齿(边缘柔化)功能,这项功能可以使大部分的图像的画面输出更柔和,降低图像的失真度。
说明
不是所有的操作系统和LibreOffice发行版都能支持此功能。
提示
使用快捷键“Shift+CTRL+R”来重新载入或刷新当前文档视图。

鼠标 – 鼠标定位

选择是否使用鼠标定位,如果是,则在一个新的对话框中指定鼠标指针定位方式。

鼠标 – 鼠标中键

定义鼠标中键的功能。
  • 自动滚动——按住鼠标中键在文档中拖动以移动视图。
  • 粘贴剪切板——按住鼠标中键,在光标所在位置插入“选择剪贴板”的内容。
说明
“选择剪贴板”与通过 编辑 > 复制/剪切/粘贴 或相应的键盘快捷键使用的剪贴板不同,是一项独立于通常剪切板的功能。在同一时刻,剪贴板和“选择剪贴板”可以含有不同的内容。
功能 剪切板 选择剪切板
复制内容 编辑 - 复制(Ctrl+C 键)。 选中文字、表格、对象。
粘贴内容 编辑 - 粘贴(Ctrl+V 键)在光标处粘贴内容。 单击鼠标中键在鼠标指针所指位置上插入内容。
粘贴到其他文档中 剪贴板的内容不受任何影响。 最后标记的选定内容就是选择剪贴板的内容。

选择 – 透明度

决定选定文本或图形时其背后出现的阴影背景。要改变这个阴影背景阴暗程度,需要更改透明度设置。数值越高,阴影越浅;反之则越深。
如果您想使选定的内容以反色显示(通常是白色的文本与黑色背景),请不要选中此项。

打印选项[编辑]

LibreOffice – 打印页面,设置适合您的默认打印机的选项及您最常用的打印方式。

图25:为LibreOffice选择打印选项

在选项页底部的“打印机警告”里,您可以选择是否在文档中指定的纸张大小或方向与您的打印机不匹配时发出警告。打开这些警告是非常有用的,特别是当您操作的文档是由其他国家的人制作的,而那些国家标准纸张的大小可能与您所在国家不同。

提示
如果您的打印出来的资料页面没有对齐,或者顶部、底部或两边被砍掉,又或者打印机拒绝打印该文件,那么最有可能的原因就是页面大小不兼容。

路径选项[编辑]

在"LibreOffice —— 路径"页面下,您可以修改文件关联,或者使用的路径,使LibreOffice更好地适合您的工作环境。例如,在Windows系统中,您可能想把文档默认存放在硬盘的其他地方而不是存放在“我的文档”。

具体修改办法是:

  1. 选择下图列表中显示其中一项,然后点击编辑
  2. 在弹出的选择路径对话框(也有不可能弹出,可能会弹出LibreOffice编辑路径对话框)里,根据您的需要来添加或者删除文件夹,然后单击确定返回到选项对话框。
提示
有些路径项目能拥有两条以上的路径,其中一条指向共享文件夹(可能是网络上的),另一条指向用户指定的文件夹(通常是在用户的个人电脑上)。
提示
通过使用“LibreOffice - 路径”对话框里的项目,您可以汇集需要备份或复制到另一个电脑的文件清单,比如那些包含自动图文集的文件夹。
图26 查看所有LibreOffice文件路径

颜色选项[编辑]

LibreOffice — 颜色页面,您可以指定在LibreOffice文档中使用的颜色。您可以从颜色表中拾取某种颜色、编辑已有的颜色和定义新的颜色。这些颜色存放您的调色板中,然后能被所有的LibreOffice组件使用。

图27 为LibreOffice定义颜色表中的颜色

修改颜色的方法:

第一步:从颜色表或者颜色下拉列表中选取要修改的颜色。
第二步:输入新的值来定义颜色,您可以选择RGB颜色模式与CMYK颜色模式中任意一种来指定您的颜色。修改后的颜色将出现顶部两个颜色预览块中下面那个。
第三步:按要求为您的颜色命名。
第四步:单击修改按钮。刚刚定义的颜色现在就列在颜色表上了。

此外,您还可以通过单击编辑按钮来打开颜色对话框,如下图所示。在这里,您可以从颜色窗口上部区域选择任意一种颜色,或在下部区域中输入数值(选择RGB,CMYK或HSB任意一种模式)产生一种颜色。

提示
在LibreOffice3.6中,颜色窗口的布局有很大的改变。

右上角的颜色窗口与下面的颜色值有直接的联系,当您选中上面颜色窗口中的某种颜色时,数值将相应地发生变化。左边颜色块选中的颜色及由右边颜色值框设定的颜色将会右下方的两个颜色块里显示。

根据需要修改好颜色组成,然后单击确定退出对话框。现在刚才定义的颜色就会在图27里顶部两个颜色预览块中下面那块中显示。在名称输入框中为刚才的颜色输入一个名称,然后单击添加按钮。一个提示框会显示新的颜色已经添加到了颜色表。

另一种方式来定义或修改某种颜色是通过颜色页的区域对话框,还可以保存和加载调色板,这个功能这里还没有实现。在Calc,绘制一个临时的图形对象,然后使用这个对象的上下文菜单就能打开区域对话框(颜色)。如果您在LibreOffice某个应用程序中载入了一组颜色,它只对当前的应用程序有效,其他的应用程序仍然保持自己的调色板不变。

图28 编辑颜色

字体选项[编辑]

如果您从他人接收到文档中含有您的电脑中没有的字体,那么LibreOffice就会为那些没有的字体使用替换字体,当然您也自己指定替代字体。您还可以为您的文档中任意一种字体定义替换字体。

图29 为LibreOffice设置字体选项

其操作步骤如下: 在LibreOffice – 字体选项页下,

第一步:勾选使用替换表选项。
第二步:在字体框中选择或输入要被替换的字体的名称。(如果您的系统没有安装这种字体,它可能不会出现在下拉字体列表中,这时您需要直接输入到里面了)
第三步:在“替换成”的字体框中,从下拉列表中选择一种在您电脑上安装的合适字体。
第四步:这时“替换成”字体框右边的对号标记变成绿色,单击这个标记。现在,在输入框下面的大输入框里就会出现一行相关信息,选中“自动”和“只显示屏幕”选项。
最后,在选项页底部,您可以修改用于源码的字体设置,如HTML与Basic(宏)。
说明
自动勾选,则无论是否安装了此字体,都使用替代字体;若不勾选,则仅在未安装此字体时使用替代字体。只显示屏幕勾选,则替代字体仅仅用于屏幕显示(如果替代可用),不用于打印;若不勾选,则用于屏幕显示和打印(如果替代可用)。
警告
自动只显示屏幕的英文原文是“Always”和“Only Screen”,因此更合适的翻译是“总是”和“仅屏幕”。
自动 只显示屏幕 替换操作
选中 空白 在屏幕上以及打印的时候替换字体(无论该字体是否安装)。
选中 选中 只在屏幕上替换字体(无论该字体是否安装)。
空白 选中 只在屏幕上替换字体(但是仅在字体不可用的情况下)。
空白 空白 在屏幕上以及打印的时候替换字体(但是仅在字体可用的情况下)。

安全性选项[编辑]

LibreOffice – 安全性选项页里,可选择保存或打开包含”宏”的文档的安全性选项。

图30:为LibreOffice选择安全性选项

安全性选项和警告

如果您在文档中记录更改,保存多个版本时或添加隐藏信息或批注时,而您又不想让一些读者看到这些信息,那么您就可以设置警告来提醒您删除这些信息,或者让LibreOffice自动删除这些信息。注:除非被删除,不论是以LibreOffice默认的ODF格式,还是以其他格式保存的文档包括PDF,这些信息都会保留在文档里。
单击“选项”按钮来打开一个带指定选项的独立对话框,在对话框里设置相关选项(参见图31)。

宏安全性

单击“宏安全性”按钮来打开宏安全性对话框(此图未显示)。在打开的对话框里,您可以调节宏安全性级别和指定可靠来源。

安全性选项和警告[编辑]

下列为“安全性选项和警告”对话框的相关选项(图31)。

保存时删除个人信息

选中此项后,当保存文档时,个人信息总是会被删除。如果您要手动删除指定文档的个人信息,则不要选中此项,然后使用菜单文件 > 属性 > 常规下的删除按钮删除个人信息。

需要按住Ctrl键并单击进入超链接

在LibreOffice中,打开超链接的默认操作是Ctrl+单击。很多人觉得这种设置可以更好地创建和编辑文件,避免因意外点击而激活链接。不选中此项,LibreOffice将使用单击来激活链接,参考图31。
图31 安全性选项和警告对话框

外观选项[编辑]

如果您可以清晰地看到页面的页边距(正文边界)、表格的边界、Writer文档的节点、Calc的分页线、Draw与Writer的网格线和其他特征,将使撰写,编辑,特别是排版变得更加便捷。您也许想使用与LibreOffice默认颜色不同的颜色来设置标注与底纹。

LibreOffice – 外观选项页(图32)里,您可以指定哪个元素可见,并为各种元素指定颜色。

  • 显示或隐藏某个元素,如正文边界的方法:选中或取消选中元素边上的单选框。
  • 修改元素的默认颜色的方法:单击元素的颜色设置框里的向下箭头,然后在弹出框中选择颜色。
  • 如您要把您修改的颜色更改作为配色方案保存,单击保存,在颜色图案框里输入名称,然后单击确定

LibreOffice 3.4新特性:阴影选项(一般组中的最后一个选项),此项用来修改Writer窗口里的页面阴影效果。

图32 显示或隐藏文字,对象和表格边界

辅助功能选项[编辑]

辅助功能选项包括是否允许动画图形或文字,帮助文本停留时间,高对比度设置和改变LibreOfficer界面字体等。

辅助功能支持依赖于Sun Microsystems公司的Java技术与辅助技术工具进行通信。详情请见下节有关“Java选项”。支持辅助技术工具选项并非在所有的LibreOffice安装中可见,详情请参考LibreOffice辅助技术帮助信息及其他需求。

案您需要选中或取消选中这些选项。

图33 选择LireOffice辅助功能选项

Java选项[编辑]

如果您在安装LibreOffice后,安装、更新了JRE(Java Runtime Environment),或者您在电脑上安装了不止一个JRE,可使用LibreOffice – Java选项页来设置LibreOffice使用的JRE。

如果您是系统管理、程序员,或者出于其他原因需要定制JRE环境,可以使用LibreOffice – Java选项下的参数Class路径页面来定制此信息。

如果您在“LibreOffice —— Java”选项页下的“已安装Java运行环境”选项框中没有看到任何东西列出,等几分钟,LibreOffice会在硬盘中搜索JRE。

如果LibreOffice识别到了不止一个JRE,它就会在“已安装Java运行环境”选项框中显示。您可以使用Java运行环境选项来选择列表中其中一个JRE。

图34 选择Java运行时环境

装入与保存设置[编辑]

通过设置装入(又译为载入)/保存选项使LibreOffice更加适应您的工作。

如果选项对话框没有打开,请单击菜单工具 > 选项。然后,再单击“装入(又译为载入)/保存”左边的展开符号(“+”或三角形)。

说明
在Windows下,许多应用程序叫做程序“载入”(Loading),“装入”是libreOffice在中文官方界面上显示的,为了便于读者使用LibreOffice,此处仍然使用装入。
图35:装入/保存选项

一般装入/保存选项[编辑]

装入/保存 — 一般选项页,大部分选项都是其他Office软件的用户非常熟悉的。下面介绍一些有趣的选项。

连同用户的设置一起装入文档 另译:把用户设置一起保存到文档中

这个功能是:在您保存一个文档时,某些用户设置也一起保存在里面。一些设置(打印机名、键接到文档的数据源)通常也会随文档一起载入,不管这个选项是否被选中。如果您选中这个选项,这些文档设置就会覆盖文档打开者的相关设置。如果您不选中,那么用户的个人设置就不会被文档中的设置所覆盖。比如这个选项会影响您原有的更新链接方式(Writer)。
图36:选择装入/保存选项

随文档一起加载打印机设置

如果这个选项没有选中,那么在您使用“直接打印”图标按钮时,文档中的原有打印机设置将会被忽略,将会使用您的系统默认打印机来代替。

保存前编辑文档属性

如果您选中此项,那么在您第一次保存新文档,或者使用另存为命令时,将会弹出文档属性对话框,提示您输入相关信息。

保存自动恢复信息的时间间隔

选择是否自动保存,以及设置自动保存信息的时间间隔。
LibreOffice自动恢复会覆盖源文件。如果您同时选中了总是创建备份副本,则原文件会覆盖副本。如果您选中此项,在系统崩溃之后恢复文档会更加容易;但恢复到早期版本可能会相当困难。

保存相对文件系统或Internet的URL地址

仅当原文档与引用文档位于同一个目录结构下时,相对文件系统地址有效,相对文件地址总是从当前文档所在目录开始。如果您想在互联网服务器上创建一个目录结构,建议您保存相对文件地址。
说明
在Microsoft Windows操作系统中,首先由磁盘分区划分,每个磁盘分区下具有目录结构。因此源文档和引用文档必须在同一个磁盘分区,相对URL地址才能正确到达。
说明
在GNU/Linux等类Uinx操作系统中,所有挂载磁盘是一个完整的目录结构。因此源文档和引用文档不必在同一个磁盘分区,相对URL地址也能正确抵达——只要它们挂载于同一个操作系统。

默认文件格式和ODF设置

ODF格式版本。LibreOffice默认以ODF 1.2扩展格式保存文档。虽然这样可以启用增强功能,却可能会有一些向前兼容性问题;如果一个使用ODF1.2扩展格式保存的文件由早期文件格式的编辑器打开,如1.0/1.1,那么一些高级特性可能就会丢失,最典型的两个例子就是标题的交叉引用和编号列表的格式。如您要与使用早期版本的ODF编辑器的人分享您的文件,请把文档保存为1.0/1.1格式。
优化ODF格式的大小。LibreOffic文档是XML文件。若您选中此项,LibreOffice写入XML数据时会除去缩进和换行。如果您想日后使用文本编辑器阅读结构化格式的XML文件,请取消此选项。
文档类型。您经常要与MS Office用户分享文档,您可能需要把“自动保存为”的文档属性改为一种MS Office文件格式。
说明
尽管LibreOffice已经能打开和保存Microsoft Office 2007及2010创建的.docx和.xlsx格式的文档,但是它目前还只能打开而无法保存.pptx格式文档。LibreOffice3.6以后的版本能够打开并保存pptx。

VBA属性装入/保存选项[编辑]

装入/保存 — VBA属性页,您可以选择,在LibreOffice打开Microsoft Office文档时,是否要装入宏。

图37:选择装入/保存VBA选项
  • 若您选中“装入Basic代码”,修改后的代码将会保存在LibreOffice文档中;但若把文档保存为Microsoft Office格式,则不会保留VBA代码。
  • 若您选中“保存原始Basic代码”,宏在LibreOffice中将无法使用;但若您以Microsoft Office格式保存文档,则可以保留VBA代码。
  • 若您导入包含VBA代码的Microsoft Word或Microsoft Excel文件,您可以选中“可执行代码”选项。然而通常情况下,VBA代码被保留但未激活(若您通过StarBasic IDE检查这些代码,将会发现它们都被注释掉了),勾选此项,则代码准备被执行。

Microsoft Office加载/保存选项[编辑]

装入/保存 – Microsoft Office页面中,您可以选择导入或导出 Microsoft Office OLE 对象的处理方式(链接或嵌入对象,或者是文档如电子表格文件与公式对象)。

  • 选中[L]选项则代表Microsoft文件装入LibreOffice后将被转换为LibreOffice文档,Microsoft OLE对象将被转换为LibreOffice OLE对象(“L”指加载对象)。
  • 选中[S]选项则代表当文档保存为Microsoft格式时,将转换LibreOffice OLE对象为Microsoft OLE对象(“S”指保存对象)。
图38:选择装入/保存Mircosoft Office选项

HTML兼容性装入/保存选项[编辑]

装入/保存 – HTML兼容性页的选项会影响HTML导入到LibreOffice及从LibreOffice导出为HTML的效果。更多信息,请参见帮助文档中的HTML文件导入导出。

字体大小

当在网页中使用时,用这些区域定义HTML标记<font size=1>到<font size=7>的字体大小。(许多页面不使用这些标记)

导入 — 使用“英语(美国)”语言设置数字格式

导入HTML页面中的数字时,千位分隔符与小数点分隔符随HTML页面所在的语言环境变化。然而,剪切板不包含语言环境信息。如果此项未被选中,数字显示方式遵照在语言设置 > 语言中的相关设置,详情参考语言设置。如果此项被选中,数字将会遵照英语(美国)语言环境显示。
图39:选择HTML兼容性选项

导入 — 将未知的HTML标记当作字段导入

若您希望将未知的HTML标记被LibreOffice当作字段导入,请选中此选项。对于开始的标记,系统会创建一个HTML_ON字段;而对于结束的标记,系统将创建一个HTML_OFF字段。这些字段在导出为HTML会转换为HTML标记。

导入 — 忽略字体设置

若此项被选中,导入HTML文件时,LibreOffice将会忽略所有的字体设置,直接使用HTML页面定义的字体样式。

导出

如您要优化HTML的导出,请从导出框中选择一种浏览器或HTML标准。如果选择LibreOffice Writer,那么指定使用LibreOffice Writer命令导出文件。

导出 — LibreOffice Basic

若选中此项,在导出为HTML文件格式时也会包含LibreOffice Basic宏(脚本)。您必须在创建LibreOffice宏之前把此项选中;否则,将无法插入脚本(宏)。LibreOffice Basic宏(脚本)必须放在HTML的头部,一旦您在LibreOffice IDE里创建了宏,它就会在HTML文件的头部显示。

导出 — 显示警告

在“LibreOffice Base”选项未选中时,“显示警告”选项就变得可用。如果选中“显示警告”选项,然后在导出为HTML文件时会显示警告信息——LibreOffice Basic宏将会丢失。

导出 — 印刷版式

若选中此项,导出当前文件时,同时也会把当前文件的印刷版式(页面设置)导出。HTML过滤器支持CSS2样式表(Cascading Style Sheets Level 2)打印文档。这些功能仅在“印刷版式”被启用时有效。

导出 — 将本地图像复制到Internet

若选中此项,在使用 FTP 进行上传时,LibreOffice会自动将內嵌片上传至网络服务器。

导出 — 字符集

为导出的文件选择恰当的字符集。

语言设置[编辑]

这个页面里有几个用来在LibreOffice定制语言设置的选项:

  • 安装您需要的字典(还没有中文字典)
  • 修改一些语言环境设置
  • 选择拼写选项

安装需要的字典[编辑]

LibrOffice会自动地安装几种字典程序。如您要添加其他的字典,您首先要连接上互联网,然后使用菜单“工具 > 语言 > 更多联机字典”。LibreOffice将会打开您的默认浏览器跳转到更多您可以安装字典的页面。根据提示选择安装您要的字典。

说明
若您使用的GNU/Linux操作系统具有软件包管理系统,你可以通过软件包管理器或类似软件中心的地方安装字典软件包。

修改语言环境设置[编辑]

您可以修改LibreOffice中一些具体的语言环境设置,应用于所有文档或指定的文档,具体步骤如下:

第一步:在选项对话框,单击语言设置 > 语言

图40:语言设置选项

第二步:在“语言设置 > 语言”页面的右边,您可以按需要修改用户界面、系统语言设置、标准货币和用于所有文档的默认文档语言。比如,英语(美国)被选用于所有适合西文的设置。

说明
如果您希望语言(字典)设置仅应用于当前文档,而不是用于所有的文档,那么请勾选“仅适用于当前文档选项”选项标签。
图41:选择语言选项

如果有必要,选中“已为亚洲语言启用”选项以支持亚洲语言(中文、日文、韩文),及选中“已为复杂的文本版式启用”来支持复杂文本语言的文字如乌尔都文、泰文、希伯来文和阿拉伯文。如果您选上述两项中任意一项,下次您打开这个对话框时,您就会在语言设置发现一些额外的选项,如下图所示。这些选项(参见中日韩文、亚洲语言文字布置和复杂文本版式)就不在此赘述了。

提示
对于中文用户,建议选中“已为亚洲语言启用”选项,更好地显示中文。
图42:开启增强语言支持后出现的附加选项页

语言规则选项[编辑]

若您要进行拼写检查设置,单击“语言设置 > 语言规则”,在选项页里,选择对您有用的设置。下面是一些建议设置:

  • 如果您不希望在您键入进行拼写检查,不要选中“键入时拼写”和选中“不要标记任何错误”(此选项在LibreOffice3.6中没有)。
  • 如果您使用的定制字典里的单词包含大小写与数字(如AS/400),选中“检查大小写字母”和“检查带编号的字”。
  • “检查特殊区域”选项下包括:页眉、页脚、边框及表格等处使用拼写检查。
图43:为拼写检查选择语言,字典和选项

在这里,您也可以使用默认激活的用户自定义字典进行拼写检查,另外单击“新建或删除”按钮就能添加或删除字典。

说明
LibreOffice有一个拼写和语法检查器叫做语言工具。您可以从菜单“工具 > 拼写和语法检查”中打开这个工具

国际互联网选项[编辑]

在“国际互联网”选项页面,您可以为LibreOffice定义搜索引擎和保存代理服务器设置。

如果您是在Windows或Linux下使用某种Mozilla的浏览器(如火狐Firefox浏览器),选中“浏览插件——在浏览器中显示文档”选项,就能在您的浏览器中打开、打印、保存或其他方式来使用LibreOffice文件。

如果您是在类Unix或类Linux操作系统(包括Mac OS X)下使用LibreOffice,会看到一个额外的选项页——E-mail选项,在这页您可以指定一个电子邮件程序以电子邮件形式发送当前文档,参见图44。而在Windows系统里,总是使用默认的电子邮件程序,因此没有此项。

图44:国际互联网选项,显示电子邮件页面(Linux)

Windows与Linux系统下的LibreOffice都默认包含一个Wiki Publisher 扩展。选择“国际互联网——MediaWiki”选项,然后单击添加按钮打开对话框,在对话框里,您可以指定一个wiki地址(URL)及账户信息,您也能添加多个Wiki到列表中。

控制LibreOffice自动更正功能[编辑]

有些人觉得LibreOffice的自动更正功能中的一些功能甚至所有功能很烦人,因为它们总是改变人们键入却不想更改的某些内容。但又有很多人觉得自动更正功能中的一些功能非常有用;如果您也这么认为,那么请选择相关选项。但如果您发现一些无法解释的“自动更正”出现在了您的文档中,那么学习本节后就可以找到原因。

若要打开自动更正对话框,点击菜单 工具>自动更正选项。(为了打开这个菜单选项,您要先打开一个文档。)

在Writer里面,这个对话框有5个标签页,就如图46所示。在LibreOffice的其他软件中,这个对话框仅有4个标签。更多的详情请参考LibreOffice其他软件指南。