LibreOffice 3.4入门/Writer入门

维基教科书,自由的教学读本
跳到导航 跳到搜索

Writer是什么?[编辑]

Writer是LibreOffice的文字处理组件。除了通常文字处理软件具有的功能(拼写检查,字典,连字号,自动纠错,查找与替换,自动行生成文章目录及索引,邮件合并等等),Writer还提供其他重要的功能:

  • 样式和模板(查看第3章使用样式和模板
  • 页面布局方法,包括框架,分栏和表格
  • 嵌入或链接图形,电子表格或者其他对象
  • 内置绘图工具
  • 汇总文档——收集多个文档合并成单一文档
  • 版本修订跟踪
  • 数据库集成,包含参考书目数据库
  • 导出成PDF格式,包括书签(查看第十章:打印,导出和电子邮件
  • 许多其他功能

这些功能会在“LibreOffice Writer 3.4指南”中详细说明。

Writer的界面[编辑]

Writer主工作空间如图63所示。菜单和工具栏如第一章LibreOffice简介描述的那样。

Writer用户界面一些其他特性将在本章涉及。

[[Image:|thumb|Figure 63: The main Writer workspace in Print Layout view]]

状态栏[编辑]

Writer状态栏提供了文档信息和快速更改文档特性的便捷方式。

[[Image:|thumb|Figure 64: Left end of status bar]]

页数

显示当前页号,当前页的序号(如果和页号不同),和文档页面总数。例如,从第三页开始重新编号,则这一页的页号为1。

说明
一般情况下,文档的页号和页的顺序号是相同的,都是从第一页编号为1。但有时前几页会有封面、前言、目录等页面,而页号从正文内容的第一页开始编号为1,因此页号会不同于页的顺序号。

如果定义了书签,右击此区域将弹出书签列表;单击需要查看的书签以跳转。

要跳转到文档中特定的页面,双击此区域。导航会打开。单击页号区域输入页面序号。稍后显示跳转到所选页面。

页面样式

显示当前页的样式。要更改页面样式,右击此区域。页面样式列表会弹出,可以从中选择不同的样式。

要编辑当前页面样式,双击此区域。页面样式对话框打开。

语言

显示选中文本的语言。

单击打开菜单,为选中文本或光标所在段落选择另一种语言。你可以选择无(不拼写检查),从拼写检查中排除一部分文本;或者选择更多...,打开字符对话框。

插入模式

单击切换插入覆盖输入模式。

选择模式

单击切换标准选择扩展选择追加选择块选选择模式。扩展选择也可以用快捷键Shift+click选择文本。参见 “处理文本”获取追加选择和块选的更多信息。

未保存更改

如果文档的更改还没有被保存,[[Image:]]图标就会替换默认图标,提示您是否要保存。

[[Image:|thumb|Figure 65: Right end of status bar]]

数字签名

如果文档已经被数字签名,这里会显示一个图标。你可以双击图标查看证书。

区域或对象信息

当光标位于节,标题,列表项,或者当一个对象(比如图片或表格)被选中,对象的信息就会出现在这个区域。双击此区域打开相关对话框。更多信息,请参阅帮助或LibreOffice Writer 3.4指南

视图布局

单击图标切换单页,双页,并排显示,和图书布局视图。显示效果和窗口宽度及缩放比例有关。您可以在任何视图中编辑文档。

[[Image:|thumb|Figure 66: View layouts: single, side-by-side, book.]]

缩放

要改变视图缩放比率,请拖动缩放滑块,或者单击+和-符号。或者右击缩放等级百分比,从弹出的缩放比率列表中选择。缩放与视图模式相互作用,决定窗口中有多少页。

[[Image:]]

更改文档视图[编辑]

Writer有多种方式查看文档:打印版式,Web版式,全屏模式。要访问这些及其他的选项,打开视图菜单,单击需要的视图模式。(全屏显示时,按下Esc键返回打印版式或Web版式。)

提示
Writer默认的视图即为打印版式,文档按照固定大小的页面被分隔。Web版式则如同网页一样,随窗口变化,没有固定的页宽,亦不分页。

处于打印版式时,状态栏上的缩放滑块和视图布局按钮都可使用。而在Web版式中,只有缩放滑块可用。

您也可以选择视图 > 缩放来显示缩放和视图布局对话框,在这里可以设置和状态栏一样的选项。在Web版式中,大多数选项将不可用。

[[Image:|thumb|Figure 67: Choosing Zoom and View Layout options.]]

在文档中快速移动[编辑]

除了前面提到的状态栏导航功能,您还可以使用第一章LibreOffice简介中提到的主导航窗口和导航工具栏。

在Writer中,您也可以单击窗口右下角滚动条之下的图标,以显示导航工具栏,如图68。

[[Image:|thumb|Figure 68: Navigation icons]]

如图69,导航工具栏显示了导航中所有对象类型的图标,包括一些额外的(例如,“查找”命令的结果)。

[[Image:|thumb|Figure 69: Navigation toolbar]]

单击图标,选择对象类型。现在所有前一个下一个图标,(导航里面的,导航工具栏上的,和滚动条上的)将跳转到选定对象类型的上一个或下一个对象。这在寻找类似索引的项时非常有帮助,因为它们在文本中很难被发现。图标的名字(显示于工具提示中),会随着所选类别而相应变化;例如“下一个图形”,“下一个书签”,“向前继续搜索”。

提示
工具提示(Tooltips)是当鼠标指针停在工具栏图标上时,出现的小文本框,包含此工具的名称和简短功能介绍。

更多Writer的导航用法,参见LibreOffice Writer 3.4指南

Writer如何处理文档[编辑]

第1章“LibreOffice简介”已经详尽介绍创建新文档、打开已有文档、保存文档及如何对文档加密等操作。第3章“使用样式和模板”阐述了如何从模板中建立文档。

另存为Microsoft Word文件[编辑]

若您要与Microsoft Word用户交换文档,而MS Word用户们常常不愿接收或者无法查看“.odt”文件,这时您就要把文件另存为Microsoft Word文件,具体步骤如下:

第一步:重要——首先把您的文件用.odt格式保存。若您不这样做的话,那么从您最后一次保存文档开始,所有的对文件的修改只会以Microsoft Word格式保存。
第二步:然后从菜单栏上选择“文件 > 另存为”。在另存为对话框,“文件类型”(或“另存为类型”)下拉菜单中选择Microsoft Word文件类型,并点击“保存”。
[[Image:|thumb|Figure 70. Saving a file in Microsoft Word format]]

从此刻开始,您所作出的所有更改将仅应用于新文档。您已经更改了文档的文件名(扩展名)和文件类型。如果您想回到ODT格式版本,必须再次打开它。

提示
要让Writer默认以Microsoft Word文件格式保存,在工具栏工具 > 选项 > 装入/保存 > 一般中设置。在“默认文件格式和ODF设置”一节,“文档类型”下面的方框,选择“文本文档”,然后在“自动保存为”下面的方框中选择您想要的文件格式。

处理文本[编辑]

在Writer中处理文本与其它程序相似。LibreOffice也提供了一些便利的方式选择非连续对象,垂直文本块,粘贴未格式化文本。

选择不连续项[编辑]

如图71,要使用鼠标选择不连续项:

  1. 选择地一个文本片段
  2. 按下 Ctrl 键不放,使用鼠标选择下一个文本片段
  3. 按需求重复第二步

现在你就可以处理选中的文本了——复制,删除,更改样式,或其他任何操作。

说明
Mac用户:请用 Command 键替代本章节乃至全读本中的 Ctrl 键。
[[Image:|thumb|Figure 71: Selecting items that are not next to each other]]

要使用键盘选择不连续项:

  1. Select the first piece of text. (For more information about keyboard selection of text, see the topic “Navigating and selecting with the keyboard” in the Help.)
  2. Press Shift+F8. This puts Writer in “Add” mode. The word ADD appears on the status bar, replacing STD.
  3. Use the arrow keys to move to the start of the next piece of text to be selected. Hold down the Shift key and select the next piece of text.
  4. Repeat as often as needed.

现在你可以处理选中的文本了。

按下 Esc 键退出此模式。

选择垂直文本块[编辑]

您可以使用LibreOffice块选模式,选择由空格和Tab分割的垂直块或列,比如从电子邮件、程序列表或其他来源粘贴的文本。要切换到块选模式,请使用编辑 > 选择模式 > 块选,或按下Ctrl+F8,或者单击状态栏的选择状态几秒钟,直到变为块选。

[[Image:]]

现在高亮显示选择,使用鼠标或键盘,如下图所示:

[[Image:|thumb|
Figure 72: Selecting a vertical block of text
]]

剪切,复制和粘贴文本[编辑]

在Writer中剪切和复制文本与其他软件类似。您可以使用鼠标或者键盘完成这些操作。您可以在一个文档或者多个文档中复制或移动文本,可以通过鼠标拖动,右键菜单,菜单栏,按钮图标,或键盘快捷键。您也可以从其他来源,如网页、邮件,复制粘贴到Writer文档中。

要使用鼠标移动(剪切粘贴)选中文本,拖拽它到一个新位置并松开鼠标。要复制(复制粘贴)选中文本,在拖动时按下 Ctrl 键不放。文本会保留原有的格式。

当你粘贴文本,结果取决于文本的源和粘贴的方式。如果你单击粘贴图标,文本的所有格式(如加粗、斜体)都会保留。从网站粘贴的文本或其他来源的文本可能会带有框架或表格。如果您不希望这样的结果,单击取消图标或按下 Ctrl+Z

要使粘贴文本呈现粘贴位置周围文本的格式:

  • 选择 编辑 > 选择性粘贴,或
  • 单击点击粘贴按钮右侧的三角形,或
  • 粘贴 图标上按下鼠标左键不放

然后从菜单中选择 未格式化文本

选择性粘贴的选项顺序取决于来源和要粘贴的文本(或其他对象)的格式。图73是一个剪切板中文本的例子。

[[Image:|thumb|Figure 73: Paste Special menu]]

查找和替换文本与格式[编辑]

Writer有两种方式在文档中查找文本:可快速搜索的查找工具栏,和查找与替换对话框。在此对话框中,你可以:

  • 查找和替换字和词
  • 使用通配符和正则表达式微调搜索
  • 查找和替换特定格式
  • 查找和替换段落样式

使用查找工具栏[编辑]

如果查找工具栏不可见,你可以在菜单栏中选择 视图 > 工具栏 > 查找 显示它,或者按下 Ctrl+F 。查找工具栏停靠在LibreOffice窗口的底部(在状态栏上面),如图74。你可以让它浮动或者停靠其他位置。更多浮动和停靠工具栏的信息,请查看第一章LibreOffice简介

[[Image:|thumb|Figure 74: Docked position of Find toolbar]]

要使用查找工具栏,在方框中输入你要搜索的文本,按下回车键查找下一个。按需要单击查找上一个查找下一个按钮。

使用“查找和替换”对话框[编辑]

要显示“查找和替换”对话框(图75),使用键盘快捷键 Ctrl+Alt+F 或从菜单栏选择编辑 > 查找和替换。也可以在查找工具栏单击更多选项弹出对话框,按钮会变为更少选项

要使用“查找和替换”对话框:

  1. 搜索框中输入要查找的文本。
  2. 要用不同的文本替代,在替换为框中输入新文本。
  3. 您可以选择多个选项,如匹配大小写,匹配整个词,或查找近义词。
  4. 当您设置好搜索之后,点击查找。要替换查找到的文本,请点击替换

查找和替换的更多信息,见LibreOffice Writer 3.4指南

提示
若点击查找全部,LibreOffice会选择文档中所有搜索文本的实例。类似地,若点击替换全部,LibreOffice会替换文档中所有符合的内容。
警告
使用全部替换时请注意,否则,你可能遇到一些令人哭笑不得的错误,那可能会非常麻烦。全部替换所造成的错误可能需要手动地逐个搜索修正。
[[Image:|thumb|Figure 75: Expanded Find & Replace dialog]]

插入特殊字符[编辑]

所谓特殊字符是在标准英语键盘上找不到的那些。例如,© ¾ æ ç ñ ö ø ¢,都是特殊字符。要插入特殊字符:

  1. 将光标放置在需要插入字符的地方。
  2. 选择 插入 > 特殊字符 打开特殊字符对话框。
  3. 按顺序选择您想插入的字符(从任何字体或者混合字体),然后点击 确定。已选的字符们会出现在对话框的左下角。而当前所选的那个字符,会在右侧显示预览,并伴有Unicode编码。
说明
不同的自体包含不同的特殊字符。如果您没有发现特定的特殊字符,尝试更换自体。
[[Image:|thumb|Figure 76: The Special Characters dialog, where you can insert special characters]]

插入破折号,不间断空格和连字符[编辑]

要避免两个英文单词在行尾被分开,在输入两个单词之间空格时按下 Ctrl+Shift

若您不想让连字符出现在行尾时中断,例如数字123‑4567,可以按下 Shift+Ctrl+minus sign 插入不中断的连字符。

要输入连字符和破折号,您可以使用工具 > 自动更正选项下方的选项标签页中的 替换破折号 选项。此选项在一定条件下用破折号替换两个连字符。

–是连字符(en),这就是说,长度和字母“n”相同的连字符。输入者少一个字符,空格,一个或两个连字符,另一个空格,至少一个字母,然后是空格。一个或两个连字符会被en连字符替代。

—是破折号(em),这就是说,长度和字母“m”相同的破折号。输入至少一个字符,两个连字符,至少一个字符,然后是空格。两个连字符会被em破折号替换。

查阅LibreOffice帮助获取更多信息。更多插入破折号的方法,请参见LibreOffice Writer 3.4指南

设置制表位和缩进[编辑]

水平标尺会显示默认制表位和自定义制表位宽度。制表位设置影响整个段落的缩进(使用格式工具栏上的“增加缩进”和“减少缩进”图标),也可以影响段落的一部分(使用键盘上的 Tab 键)。

如果您与其他人分享文档,使用默认制表位宽度可能会导致格式问题。如果您的默认制表位宽度与其他人不同,当文档分享给他们之后,会以他们的设置重新显示,导致格式显示的差异。要替换默认设置,您需要按如下所述定义自己的缩进设置。

要定义选中段落的缩进和制表位设置,双击标尺的除左右缩进图标之间的部分打开缩进与空格对话框。双击标尺左右缩进图标之间的任意部分打开制表位对话框。

更好的策略是定义段落样式的缩进。查看LibreOffice Writer 3.4指南的第六、七章获取更多信息。

提示
不建议您使用缩进分割内容。使用表格可能是更好的选择,当然,这取决于您想达到的目的。

更改默认制表位间隔[编辑]

提示
默认制表位设置的更改会影响你所打开的任何文档的默认制表位,包括之后输入的制表位。

要设置默认制表位间隔的度量单位和空间,打开菜单工具 > 选项 > LibreOffice Writer > 一般

[[Image:|thumb|Figure 77: Selecting a default tab stop interval]]

你也可以设置或改变标尺的度量单位,只要右击标尺打开度量单位列表选择即可。选择的设置仅仅应用于当前文档的标尺。

[[Image:|thumb|
Figure 78: Changing the measurement unit for a ruler
]]

检查拼写和语法[编辑]

Writer提供了拼写检查,可以以两种方式使用:

[[Image:]] 自动拼写检查 在每一个单词输入时对其检查拼写并显示红色波浪线标记错误单词。当单词正确时,红线会消失。
[[Image:]] 要在文档中(或选中文本中)执行单独的拼写检查,点击 拼写和语法 按钮。Writer将检查文档或选中文本,如果有错误会打开“拼写和语法”对话框。

拼写检查的更多特性:

  • 您可以右击一个带有波浪线标记的词打开右键菜单。如果您从菜单的建议单词中选择,选择的单词会替换现在的单词。其他菜单选项如下所述。
  • 您可以在“拼写和语法”对话框更改字典语言(比如,西班牙语,法语,德语,中文)。
  • 您可以添加单词到字典。在“拼写和语法”对话框点击 添加 并选择要添加到的字典。
  • 在“拼写和语法”对话框点击 选项 按钮打开一个对话框,类似于第二章描述的 工具 > 选项 > 语言设置 > 写作助手。There you can choose whether to check uppercase words and words with numbers, and you can manage custom dictionaries, that is, add or delete dictionaries and add or delete words in a dictionary.
  • On the Font tab of the Paragraph Styles dialog, you can set paragraphs to be checked in a specific language (different from the rest of the document). See Chapter 7, Working with Styles, in the Writer Guide for more information.

Writer does not include a grammar checker, but you can install an extension such as Language Tool (from http://www.languagetool.org/) and access it from Tools > Spelling and Grammar. (See Chapter 14 for more about installing extensions.)

  • Language Tool adds a new menu item and submenu to the Tools menu, from which you can configure the tool and check or recheck the document.

使用内建语言工具[编辑]

Writer provides some tools that make your work easier if you mix multiple languages within the same document or if you write documents in various languages.

The main advantage of changing the language for a text selection is that you can then use the correct dictionaries to check spelling and apply the localized versions of Autocorrect replacement tables, thesaurus, and hyphenation rules.

You can also set the language for a paragraph or a group of characters as None (Do not check spelling). This option is especially useful when you insert text such as web addresses or programming language snippets that you do not want to check for spelling.

Specifying the language in character and paragraph styles is the preferred method, because styles allow a greater level of control and make changing the language much faster. On the Font tab of the Paragraph Styles dialog, you can specify that certain paragraphs be checked in a language that is different from the language of the rest of the document. See Chapter 7, Working with Styles, in the Writer Guide for information on how to manage the language settings of a style.

You can also set the language for the whole document, for individual paragraphs, or even for individual words and characters, from Tools > Language on the menu bar.

Another way to change the language of a whole document is to use Tools > Options > Language Settings > Languages. In the Default languages for documents section, you can choose a different language for all the text that is not explicitly marked as a different language.

The spelling checker works only for those languages in the list that have the symbol [[Image:]] next to them. If you do not see the symbol next to your preferred language, you can install the additional dictionary using Tools > Languages > More dictionaries online.

The language used for checking spelling is also shown in the status bar, next to the page style in use.

使用自动更正[编辑]

Writer’s AutoCorrect function has a long list of common misspellings and typing errors, which it corrects automatically. For example, “hte” will be changed to “the”.

AutoCorrect is turned on when Writer is installed. To turn it off, uncheck Format > AutoCorrect > While Typing.

Choose Tools > AutoCorrect Options to open the AutoCorrect dialog. There you can define which strings of text are corrected and how. In most cases, the defaults are fine.

To stop Writer replacing a specific spelling, go to the Replace tab, highlight the word pair, and click Delete.

To add a new spelling to the list, type it into the Replace and With boxes on the Replace tab, and click New.

See the different tabs of the dialog for the wide variety of other options available to fine-tune AutoCorrect.


提示
AutoCorrect can be used as a quick way to insert special characters. For example, (c) will be autocorrected to ©. You can add your own special characters.

使用单词补全[编辑]

If Word Completion is enabled, Writer tries to guess which word you are typing and offers to complete the word for you. To accept the suggestion, press Enter. Otherwise, continue typing.

To turn off Word Completion, select Tools > AutoCorrect Options > Word Completion and deselect Enable word completion.

You can customize word completion from the Word Completion page of the AutoCorrect dialog:

  • Add (append) a space automatically after an accepted word
  • Show the suggested word as a tip (hovering over the word) rather than completing the text as you type
  • Collect words when working on a document, and then either save them for later use in other documents or select the option to remove them from the list when closing the document.
  • Change the maximum number of words remembered for word completion and the length of the smallest words to be remembered
  • Delete specific entries from the word completion list
  • Change the key that accepts a suggested entry—the options are Right arrow, End key, Return (Enter), and Space bar
说明
Automatic word completion only occurs after you type a word for the second time in a document.

使用自动图文集[编辑]

Use AutoText to store text, tables, graphics and other items for reuse and assign them to a key combination for easy retrieval. For example, rather than typing “Senior Management” every time you use that phrase, you can set up an AutoText entry to insert those words when you type “sm” and press F3.

AutoText is especially powerful when assigned to fields. See Chapter 14, Working with Fields, in the Writer Guide for more information.

创建自动图文集[编辑]

To store some text as AutoText:

  1. Type the text into your document.
  2. Select the text.
  3. Choose Edit > AutoText (or press Ctrl+F3).
  4. In the AutoText dialog box, type a name for the AutoText in the Name box. Writer will suggest a one-letter shortcut, which you can change.
  5. In the large box to the left, choose the category for the AutoText entry, for example My AutoText.
  6. Click the AutoText button on the right and select New (text only) from the menu.
  7. Click Close to return to your document.


提示
If the only option under the AutoText button is Import, either you have not entered a name for your AutoText or there is no text selected in the document.

插入自动图文集[编辑]

输入快捷方式并按下 F3 以插入自动图文集。

文本格式[编辑]

推荐使用样式[编辑]

样式是使用Writer的核心。您可以使用样式轻松地将文档格式化一致,并轻易更改。样式是一组格式设置选项的名称。当您使用一种样式,您将同时应用整组格式。此外,样式用于LibreOffice的很多处理,即使您未曾察觉。例如,Writer编辑目录时依赖标题样式(或其他制定样式)。
Styles are central to using Writer. Styles enable you to easily format your document consistently, and to change the format with minimal effort. A style is a named set of formatting options. When you apply a style, you apply a whole group of formats at the same time. In addition, styles are used by LibreOffice for many processes, even if you are not aware of them. For example, Writer relies on heading styles (or other styles you specify) when it compiles a table of contents.


Caution
Manual formatting (also called direct formatting) overrides styles, and you cannot get rid of the manual formatting by applying a style to it.

To remove manual formatting, select the text, right-click, and choose Clear Direct Formatting from the pop-up menu.

Writer defines several types of styles, for different types of elements: characters, paragraphs, pages, frames, and lists. See Chapter 3, Using Styles and Templates, in this book and Chapters 6 and 7 in the Writer Guide.

段落格式[编辑]

您可以利用格式工具栏上的按钮应用多种段落格式。图79为浮动格式工具栏,自定义显示段落格式图标。图标外观随操作系统和图标大小及风格的选择改变,可以在 工具 > 选项 > LibreOffice > 视图中修改。
You can apply many formats to paragraphs using the buttons on the Formatting toolbar. Figure 79 shows the Formatting toolbar as a floating toolbar, customized to show only the icons for paragraph formatting. The appearance of the icons may vary with your operating system and the selection of icon size and style in Tools > Options > LibreOffice > View.

[[Image:|thumb|Figure 79: Formatting toolbar, showing icons for paragraph formatting]]
  • 1 打开样式和格式窗口
  • 2 应用样式
  • 3 左对齐
  • 4 居中
  • 5 右对齐
  • 6 两端对齐
  • 7 行间距: 1
  • 8 行间距: 1.5
  • 9 行间距: 2
  • 10 编号 开/关
  • 11 项目 开/关
  • 12 减少缩进
  • 13 增加缩进
  • 14 段落格式对话窗口

字体格式[编辑]

You can apply many formats to characters using the buttons on the Formatting toolbar. Figure 80 shows the Formatting toolbar, customized to include only the icon for character formatting.

The appearance of the icons may vary with your operating system and the selection of icon size and style in Tools > Options > LibreOffice > View.

[[Image:|thumb|Figure 80: Formatting toolbar, showing icons for character formatting]]
Tip
To remove manual formatting, select the text and choose Format > Default Formatting, or right-click and choose Default Formatting.

自动套用格式[编辑]

You can set Writer to automatically format parts of a document according to the choices made on the Options page of the AutoCorrect dialog (Tools > AutoCorrect Options).


Tip
If you notice unexpected formatting changes occurring in your document, this is the first place to look for the cause.

The Help describes each of these choices and how to activate the autoformats. Some common unwanted or unexpected formatting changes include:

  • Horizontal lines. If you type three or more hyphens (---), underscores (___) or equal signs (===) on a line and then press Enter, the paragraph is replaced by a horizontal line as wide as the page. The line is actually the lower border of the preceding paragraph.
  • Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), star (*), or plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered list is created when you type a number followed by a period (.), followed by a space or tab at the beginning of a paragraph. Automatic numbering is only applied to paragraphs formatted with the Default, Text body or Text body indent paragraph styles.

To turn autoformatting on or off, choose Format > AutoCorrect and select or deselect the items on the list.

创建编号或项目符号列表[编辑]

There are several ways to create numbered or bulleted lists:

  • Use autoformatting, as described above.
  • Use list (numbering) styles, as described in Chapter 6, Introduction to Styles, and Chapter 7, Working with Styles, in the Writer Guide.
  • Use the Numbering and Bullets icons on the paragraph formatting toolbar (see Figure 79): select the paragraphs in the list, and then click the appropriate icon on the toolbar.


Note
It is a matter of personal preference whether you type your information first, then apply Numbering/Bullets, or apply them as you type.

使用项目符合和编号工具栏[编辑]

You can create nested lists (where one or more list items has a sub-list under it, as in an outline) by using the buttons on the Bullets and Numbering toolbar (Figure 81). You can move items up or down the list, or create sub-points, and even change the style of bullets. Use View > Toolbars > Bullets and Numbering to see the toolbar.

The appearance of the icons may vary with your operating system and the selection of icon size and style in Tools > Options > LibreOffice > View.


Note
If numbering or bullets are being applied automatically in a way that you find inappropriate, you can switch them off temporarily by unchecking Format > AutoCorrect > While Typing.
[[Image:|thumb|Figure 81: Bullets and Numbering toolbar]]

Hyphenating words[编辑]

You have several choices regarding hyphenation: let Writer do it automatically (using its hyphenation dictionaries), insert conditional hyphens manually where necessary, or don’t hyphenate at all.

Automatic hyphenation[编辑]

[[Image:|thumb|Figure 82: Modifying a style]]To turn automatic hyphenation of words on or off:

  1. Press F11 (z+T on Mac) to open the Styles and Formatting window.
  2. On the Paragraph Styles page (Figure 82), right-click on Default and select Modify.
  3. On the Paragraph Style dialog (Figure 83), go to the Text Flow page.
  4. Under Hyphenation, select or deselect the Automatically option. Click OK to save.
[[Image:|thumb|Figure 83: Turning on automatic hyphenation]]


Note
Turning on hyphenation for the Default paragraph style affects all other paragraph styles that are based on Default. You can individually change other styles so that hyphenation is not active; for example, you might not want headings to be hyphenated. Any styles that are not based on Default are not affected. See Chapter 3, Styles and Templates, for more about styles based on other styles.

You can also set hyphenation choices through Tools > Options > Language Settings > Writing Aids. In Options, near the bottom of the dialog, scroll down to find the hyphenation settings.

[[Image:|thumb|Figure 84: Setting hyphenation options]]

To change the minimum number of characters for hyphenation, the minimum number of characters before a line break, or the minimum number of characters after a line break, select the item, and then click the Edit button in the Options section.

Hyphenation options set on the Writing Aids dialog are effective only if hyphenation is turned on through paragraph styles.

Manual hyphenation[编辑]

To manually hyphenate words, do not use a normal hyphen, which will remain visible even if the word is no longer at the end of a line when you add or delete text or change margins or font size. Instead, use a conditional hyphen, which is visible only when required.

To insert a conditional hyphen inside a word, click where you want the hyphen to appear and press Ctrl+hyphen. The word will be hyphenated at this position when it is at the end of the line, even if automatic hyphenation for this paragraph is switched off.

页面格式[编辑]

Writer provides several ways for you to control page layouts: page styles, columns, frames, tables, and sections. For more information, see Chapter 4, Formatting Pages, in the Writer Guide.


Tip
Page layout is usually easier if you show text, object, table, and section boundaries in Tools > Options > LibreOffice > Appearance, and paragraph ends, tabs, breaks, and other items in Tools > Options > LibreOffice Writer > Formatting Aids.

Which layout method to choose?[编辑]

The best layout method depends on what the final document should look like and what sort of information will be in the document. Here are some examples.


For a book similar to this user guide, with one column of text, some figures without text beside them, and some other figures with descriptive text, use page styles for basic layout, and tables to place figures beside descriptive text when necessary.
[[Image:]]
For an index or other document with two columns of text, where the text continues from the left-hand column to the right-hand column and then to the next page, all in sequence (also known as “snaking columns” of text), use page styles (with two columns). If the title of the document (on the first page) is full-page width, put it in a single-column section.
[[Image:]]
For a newsletter with complex layout, two or three columns on the page, and some articles that continue from one page to some place several pages later, use page styles for basic layout. Place articles in linked frames and anchor graphics to fixed positions on the page if necessary.
[[Image:]]
For a document with terms and translations to appear side-by-side in what appear to be columns, use a table to keep items lined up, and so you can type in both “columns”.
[[Image:]]

Creating headers and footers[编辑]

A header is an area that appears at the top of a page. A footer appears at the bottom of the page. Information such as page numbers inserted into a header or footer displays on every page of the document with that page style.

To insert a header, choose Insert > Header > Default (or the page style, if not Default).

Other information such as document titles and chapter titles is often put into the header or footer. These items are best added as fields. That way, if something changes, the headers and footers are updated automatically. Here is one common example.

To insert the document title into the header:

  1. Choose File > Properties > Description and type a title for your document.
  2. Add a header (Insert > Header > Default).
  3. Place the cursor in the header part of the page.
  4. Choose Insert > Fields > Title. The title should appear on a gray background (which does not show when printed and can be turned off).
  5. To change the title for the whole document, go back to File > Properties > Description.

Fields are covered in detail in Chapter 14, Working with Fields, in the Writer Guide.

For more about headers and footers, see Chapter 4, Formatting Pages, and Chapter 6, Introduction to Styles, in the Writer Guide.

Numbering pages[编辑]

To automatically number pages:

  1. Insert a header or footer, as described in “Creating headers and footers” above.
  2. Place the cursor in the header or footer where you want the page number to appear and choose Insert > Fields > Page Number.

Including the total number of pages[编辑]

To include the total number of pages (as in “page 1 of 12”):

  1. Type the word “page” and a space, then insert the page number as above.
  2. Press the spacebar once, type the word “of” and a space, then choose Insert > Fields > Page Count.


Note
The Page Count field inserts the total number of pages in the document, as shown on the Statistics tab of the document’s Properties window (File > Properties). If you restart page numbering anywhere in the document, then the total page count may not be what you want. See Chapter 4, Formatting Pages, in the Writer Guide for more information.

Restarting page numbering[编辑]

Often you will want to restart the page numbering at 1, for example on the page following a title page or a table of contents. In addition, many documents have the “front matter” (such as the table of contents) numbered with Roman numerals and the main body of the document numbered in Arabic numerals, starting with 1.

You can restart page numbering in two ways.

Method 1:

  1. Place the cursor in the first paragraph of the new page.
  2. Choose Format > Paragraph.
  3. On the Text Flow tab of the Paragraph dialog (Figure 83 on page 92), select Breaks.
  4. Select Insert and then With Page Style and specify the page style to use.
  5. Specify the page number to start from, and then click OK.


Tip
Method 1 is also useful for numbering the first page of a document with a page number greater than 1. For example, you may be writing a book, with each chapter in a separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with page 25 and Chapter 3 with page 51.

Method 2:

  1. Insert > Manual break.
  2. By default, Page break is selected on the Insert Break dialog (Figure 85).
  3. Choose the required page Style.
  4. Select Change page number.
  5. Specify the page number to start from, and then click OK.
[[Image:|thumb|
Figure 85: Restarting page numbering after a manual page break
]]

修改页边距[编辑]

You can change page margins in two ways:

  • 使用标尺—快捷简单,但无法精确控制
  • 使用页面格式对话框—可以指定边距到百分位
  • Using the page rulers—quick and easy, but does not have fine control
  • Using the Page Style dialog—can specify margins to two decimal places


Note
If you change the margins using the rulers, the new margins affect the page style and will be shown in the Page Style dialog the next time you open it.

Because the page style is affected, the changed margins apply to all pages using that style.

To change margins using the rulers:

  1. The gray sections of the rulers are the margins. Put the mouse cursor over the line between the gray and white sections. The pointer turns into a double-headed arrow.
  2. Hold down the left mouse button and drag the mouse to move the margin.
[[Image:|thumb|Figure 86: Moving the margins]]


Tip
The small arrowheads on the ruler are used for indenting paragraphs. They are often in the same place as the page margins, so you need to be careful to move the margin marker, not the arrows. Place the mouse pointer between the arrows and, when the pointer turns into a double-headed arrow, you can move the margin (the indent arrows will move with it).

To change margins using the Page Style dialog:

  1. Right-click anywhere on the page and select Page from the pop-up menu.
  2. On the Page tab of the dialog, type the required distances in the Margins boxes.

给文档添加批注[编辑]

Authors and reviewers often use comments (formerly called “notes”) to exchange ideas, ask for suggestions, or mark items needing attention.

To insert a comment in the text, place the cursor in the place the comment refers to and choose Insert > Comment or press Ctrl+Alt+C. The anchor point of the comment is connected by a dotted line to a box on the right-hand side of the page where you can type the text of the comment. Writer automatically adds at the bottom of the comment the author’s name and a time stamp indicating when the comment was created. Figure 87 shows an example of text with comments from two different authors.

[[Image:|thumb|Figure 87: Example of comments]]

Choose Tools > Options > User Data to configure the name you want to appear in the Author field of the comment, or to change it.

If more than one person edits the document, each author is automatically allocated a different background color.

Right-clicking on a comment pops up a menu where you can delete the current comment, all the comments from the same author, or all the comments in the document. From this menu, you can also apply some basic formatting to the text of the comment. You can also change the font type, size, and alignment from the main menu.

To navigate from one comment to another, open the Navigator (F5), expand the Comments section, and click on the comment text to move the cursor to the anchor point of the comment in the document. Right-click on the comment to quickly edit or delete it.

You can also navigate through the comments using the keyboard. Use Ctrl+Alt+Page Down to move to the next comment and Ctrl+Alt+Page Up to move to the previous comment.

创建目录[编辑]

Writer’s table of contents feature lets you build an automated table of contents from the headings in your document. Before you start, make sure that the headings are styled consistently. For example, you can use the Heading 1 style for chapter titles and the Heading 2 and Heading 3 styles for chapter subheadings.

Although tables of contents can be customized extensively in Writer, often the default settings are all you need. Creating a quick table of contents is simple:

  1. When you create your document, use the following paragraph styles for different heading levels (such as chapter and section headings): Heading 1, Heading 2, Heading 3, and so on. These are what will appear in your table of contents.
  2. Place the cursor where you want the table of contents to be inserted.
  3. Choose Insert > Indexes and Tables > Indexes and Tables.
  4. Change nothing in the Insert Index/Table dialog. Click OK.

If you add or delete text (so that headings move to different pages) or you add, delete, or change headings, you need to update the table of contents.

To do this:

  1. Place the cursor within the table of contents.
  2. Right-click and choose Update Index/Table from the pop-up menu.


Note
If you cannot place your cursor in the table of contents, choose Tools > Options > LibreOffice Writer > Formatting Aids, and then select Enable in the Cursor in protected areas section.

You can customize an existing table of contents at any time. Right-click anywhere in it and choose Edit Index/Table from the pop-up menu. Chapter 12, Creating Tables of Contents, Indexes and Bibliographies, of the Writer Guide describes in detail all the customizations you can choose.

创建索引和书目[编辑]

Indexes and bibliographies work in a similar way to tables of contents. Chapter 12, Creating Tables of Contents, Indexes and Bibliographies, in the Writer Guide describes the process in detail.

In addition to alphabetical indexes, other types of indexes supplied with Writer include those for illustrations, tables, and objects, and you can even create a user-defined index. For example, you might want an index containing only the scientific names of species mentioned in the text, and a separate index containing only the common names of species. Before creating some types of indexes, you first need to create index entries embedded in your Writer document.

使用图形[编辑]

Graphics in Writer are of three basic types:

  • Image files, including photos, drawings, scanned images, and others
  • Diagrams created using LibreOffice’s drawing tools
  • Charts created using LibreOffice’s Chart component

See Chapter 11, Graphics, the Gallery, and Fontwork, in this book and Chapter 8, Working with Graphics, in the Writer Guide.

打印[编辑]

See Chapter 10, Printing, Exporting, and E‑mailing, in this book and Chapter 5, Printing, Exporting, Faxing, and E‑mailing, in the Writer Guide for details on previewing pages before printing, selecting print options, printing in black and white on a color printer, printing brochures, and other printing features.

邮件合并[编辑]

Writer provides very useful features to create and print:

  • Multiple copies of a document to send to a list of different recipients (form letters)
  • Mailing labels
  • Envelopes

All these facilities use a registered data source (a spreadsheet or database containing the name and address records and other information). Chapter 11, Using Mail Merge, in the Writer Guide describes the process.

跟踪文档变化[编辑]

You can use several methods to keep track of changes made to a document.

  1. Make your changes to a copy of the document (stored in a different folder, or under a different name, or both), then use Writer to combine the two files and show the differences. Choose Edit > Compare Document. This technique is particularly useful if you are the only person working on the document, as it avoids the increase in file size and complexity caused by the other methods.
  2. Save versions that are stored as part of the original file. However, this method can cause problems with documents of non-trivial size or complexity, especially if you save a lot of versions. Avoid this method if you can.
  3. Use Writer’s change marks (often called “redlines” or “revision marks”) to show where you have added or deleted material, or changed formatting. Choose Edit > Changes > Record. Later, you or another person can review and accept or reject each change. Right-click on an individual change and choose Accept Change or Reject Change from the pop-up menu, or choose Edit > Changes > Accept or Reject to view the list of changes and accept or reject them. Details are in the Writer Guide.


Tip
Not all changes are recorded. For example, changing a tab stop from align left to align right, and changes in formulas (equations) or linked graphics are not recorded.

使用字段[编辑]

Fields are extremely useful features of Writer. They are used for data that changes in a document (such as the current date or the total number of pages) and for inserting document properties such as name, author, and date of last update. Fields are the basis of cross-referencing (see below); automatic numbering of figures, tables, headings, and other elements; and a wide range of other functions—far too many to describe here. See Chapter 14, Working with Fields, in the Writer Guide for details.

链接至文档的另一部分[编辑]

If you type in cross-references to other parts of a document, those references can easily get out of date if you reorganize the order of topics, add or remove material, or reword a heading. Writer provides two ways to ensure that your references are up to date, by inserting links to other parts of the same document or to a different document:

  • Hyperlinks
  • Cross-references

The two methods have the same result if you Ctrl+click the link when the document is open in Writer: you are taken directly to the cross-referenced item. However, they also have major differences:

  • The text in a hyperlink does not automatically update if you change the text of the linked item (although you can change it manually), but changed text does automatically update in a cross-reference.
  • When using a hyperlink, you do not have a choice of the content of the link (for example text or page number), but when using a cross-reference, you have several choices, including bookmarks.
  • To hyperlink to an object such as a graphic, and have the hyperlink show useful text such as Figure 6, you need to give such an object a useful name (instead of a default name like Graphics6), or use the Hyperlink dialog to modify the visible text. In contrast, cross-references to figures with captions automatically show useful text, and you have a choice of several variations of the name.
  • If you save a Writer document to HTML, hyperlinks remain active but cross-references do not. (Both remain active when the document is exported to PDF.)

使用超级链接[编辑]

The easiest way to insert a hyperlink to another part of the same document is by using the Navigator:

  1. Open the document containing the items you want to cross-reference.
  2. Open the Navigator by clicking its icon, choosing View > Navigator, or pressing F5.
  3. Click the arrow next to the Drag Mode icon, and choose Insert as Hyperlink.
  4. In the list at the bottom of the Navigator, select the document containing the item that you want to cross-reference.
  5. In the Navigator list, select the item that you want to insert as a hyperlink.
  6. Drag the item to where you want to insert the hyperlink in the document. The name of the item is inserted in the document as an active hyperlink.
[[Image:|thumb|Figure 88: Inserting a hyperlink using the Navigator]]

You can also use the Hyperlink dialog to insert and modify hyperlinks within and between documents. See Chapter 12, Creating Web Pages.

使用交叉引用[编辑]

If you type in references to other parts of the document, those references can easily get out of date if you reword a heading, add or remove figures, or reorganize topics. Replace any typed cross-references with automatic ones and, when you update fields, all the references will update automatically to show the current wording or page numbers. The Cross-references tab of the Fields dialog lists some items, such as headings, bookmarks, figures, tables, and numbered items such as steps in a procedure. You can also create your own reference items; see “Setting References” in Chapter 14, Working with Fields, in the Writer Guide for instructions.

To insert a cross-reference to a heading, figure, bookmark, or other item:

  1. In your document, place the cursor where you want the cross-reference to appear.
  2. If the Fields dialog is not open, click Insert > Cross-reference. On the Cross-references tab (Figure 89), in the Type list, select the type of item to be referenced (for example, Heading or Figure). You can leave this page open while you insert many cross-references.
  3. Click on the required item in the Selection list, which shows all the items of the selected type. In the Insert reference to list, choose the format required. The list varies according to the Type. The most commonly used options are Reference (to insert the full text of a heading or caption), Category and Number (to insert a figure number preceded by the word Figure or Table, but without the caption text), Numbering (to insert only the figure or table number, without the word “Figure” or “Table”), or Page (to insert the number of the page the referenced text is on). Click Insert.
[[Image:|thumb|Figure 89: The Cross-references tab of the Fields dialog ]]

使用书签[编辑]

Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse click. You can cross-reference to bookmarks and create hyperlinks to bookmarks, as described above.

  1. Select the text you want to bookmark. Click Insert > Bookmark.
  2. On the Insert Bookmark dialog, the larger box lists any previously defined bookmarks. Type a name for this bookmark in the top box, and then click OK.
[[Image:|thumb|Figure 90: Inserting a bookmark]]

使用主文档[编辑]

Master documents are typically used for producing long documents such as a book, a thesis, or a long report; or when different people are writing different chapters or other parts of the full document, so you don’t need to share files. A master document joins separate text documents into one larger document, and unifies the formatting, table of contents (TOC), bibliography, index, and other tables or lists.

Yes, master documents do work in Writer. However, until you become familiar with them, you may think that master documents are unreliable or difficult to use. See Chapter 13, Working with Master Documents, in the Writer Guide.

Creating fill-in forms[编辑]

A standard text document displays information: a letter, report, or brochure, for example. Typically the reader may either edit everything or nothing in any way. A form has sections that are not to be edited, and other sections that are designed for the reader to make changes. For example, a questionnaire has an introduction and questions (which do not change) and spaces for the reader to enter answers.

Forms are used in three ways:

  • To create a simple document for the recipient to complete, such as a questionnaire sent out to a group of people who fill it in and return it.
  • To link into a database or data source and allow the user to enter information. Someone taking orders might enter the information for each order into a database using a form.
  • To view information held in a database or data source. A librarian might call up information about books.

Writer offers several ways to fill information into a form, including check boxes, option buttons, text boxes, pull-down lists and spinners. See Chapter 15, Using Forms in Writer, in the Writer Guide.